<< | Thread Index | >> ]    [ << | Date Index | >> ]

Subject: Re: cipe beta 11 on win2000
From: "Damion K. Wilson" <dkw,AT,rcm,DOT,bm>
Date: Wed, 11 Oct 2000 01:30:12 +0200
In-reply-to: <200010102323.RAA02829@saturne.robots.com>

Hmm, it seems as though there is something environmentally different on
your box than on mine. You shouldn't have to recompile it, though. The
problem will be in the inf file and how Windows 2000 interprets it.

Running the CPL applet won't help either because it expects Windows to have
created all the proper registry entries...

<RANT MODE=1>

This registry crap is the worst thing that computer science has seen since
the moth flew into ENIAC !!!

</RANT>

All I can tell you is to uninstall CIPE, remove all remnants of it from the
registry, reboot twice, and install from scratch. If you do not see a CIPE
adapter in Windows 2000's Network Connections folder, the inf script has
failed to create the registry entries.

If you look in
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11C
E-BFC1-08002BE10318}, you will see a bunch of keys with numeric names
(0001, 0002, ...) Each of these represents a network adapter on your
machine. The CIPE ones have a ProviderName fields with DKWHeavyIndustries.

Also, CIPE-Win32 will NOT work in Win2K BETA. The developers changed a
bunch of things prior to release that make network install procedures
different.

DKW

*********** REPLY SEPARATOR  ***********

On 10/10/00 at 5:23 PM Philippe Moutarlier wrote:

>Hi,
>
>I have been using cipe on linux for almost a year now : great job !!!
>
>Now, my company is moving to some Windows firewall (???!! weird, isn't it
...) and I am trying to setup cipe on Win2k. 
>
>I tried the binaries, but here I am confused :
>
>- after installing (successfully) the network adapter, no configuration
window shows up as mentionned in the readme file. Where should I put the
cipe parameters ?
>
>- no services show in the list of win 2000 services
>
>- I can run the cpl file CipePanel manually but I don't know to what
interface it is related. Nor do I see where to setup the routing stuff. Do
I have to establish static routes separately ?
>
>Ah, also : I rebooted as it is usually necessary with windows (even if it
doesn't ask).
>
>I tried to recompile the thing but I am missing a file "iphlapi.h" which
is nowhere to be found on my entire system (I am using VC++ 6 as compiler).
>
>
>Thanks for any help
>
>Philippe
>
>--
>Message sent by the cipe-l,AT,inka,DOT,de mailing list.
>Unsubscribe: mail majordomo,AT,inka,DOT,de, "unsubscribe cipe-l" in body
>Other commands available with "help" in body to the same address.
>CIPE info and list archive:
<URL:http://sites.inka.de/~bigred/devel/cipe.html>





<< | Thread Index | >> ]    [ << | Date Index | >> ]