<< | Thread Index | >> ]    [ << | Date Index | >> ]

Subject: Re: CIPE-win32 v2.0-pre2 -> CIPE 1.4.3 = frame errors
From: "Ville Voipio" <ville.voipio,AT,iki,DOT,fi>
Date: Thu, 23 Nov 2000 10:15:52 +0100
In-reply-to: <3A1ACAED.77317E75@art-render.com>

Mike,

The UDP checksum seems to be fine. I get a 0xffff as the sum. Also all
length fields seem to be correct. So, the packet seems to be fine to the
last bit. Which makes me wonder, as the CIPE complains about "frame error".

I had some similar problems (in addition to the UDP checksum problem). I
tried several CIPE versions, and then I tried changing the port numbers so
that the numbers are different on different computers. Something helped
because I cannot reproduce the frame errors with my setup anymore.

---

> Can you confirm/deny that the checksums are OK?

They seem to be ok. I did not calculate the IP checksum, but if it were
wrong, the O/S should have dropped the packet. Also, Linux' tcpdump should
complain about erraneous checksums (windump does not, unfortunately).

---

The next steps I suggest:

1. Try tcpdumping the cipcb2 -interface. Are there any packets?

2. Start cip-cb with debug = true. That will allow you to see key exchange
messages and possible other complaints.

3. Try pinging the other way round (from the Linux machine). tcp/windump the
activity in both ends. Is the ping received by the W2k laptop on UDP or CIPE
level?

Best regards,

- Ville





<< | Thread Index | >> ]    [ << | Date Index | >> ]