<< | Thread Index | >> ]    [ << | Date Index | >> ]

Subject: need help on multiple cipe devices
From: "Vahedipour, Kaveh" <kv,AT,cm-ag,DOT,de>
Date: Thu, 30 Nov 2000 21:55:32 +0100

Hi!

Please help me with this. I am kind of desperate now. I have read anything I
could find on multiple cipe devices. But could'nt find any help on this.
This is a linux box with kernel 2.2.16. I have no idea how I can bind ciped
to the second interface. I have to do that since eth0 is a cipe device too.
The configration is supposed to connect two independent subnets to our main
net. Do I have to modify ip-up? I could not find any hint on what exactly
has to be changed. The first interface goes up with no errors.

/etc/cipe/option-0: ---------------------

ptpaddr         192.168.251.1
ipaddr          192.168.251.251

me              192.168.11.251:9999
peer            192.168.11.1:9999  

key             <key>

ipup            /etc/cipe/ip-up-0

device          cipcb0
-----------------------------------------

/etc/cipe/option-1: ---------------------

ptpaddr         192.168.253.3
ipaddr          192.168.253.253

me              192.168.13.253:9990
peer            192.168.13.3:9990

debug           1

key             <key>

ipup            /etc/cipe/ip-up-1

device          cipcb1
-----------------------------------------

Running ciped-cb for that interface shows the following.

-----------------------------------------
/etc/cipe # ciped-cb -o /etc/cipe/option-1
CIPE daemon vers 1.4.5 (c) Olaf Titz 1996-2000
device=cipcb1
debug=yes
ipaddr=192.168.253.253
ptpaddr=192.168.253.3
mtu=0
metric=0
cttl=0
me=192.168.13.253:9990
peer=192.168.13.3:9990
key=(secret)
nokey=no
socks=
tokxc=0
tokey=0
ipup=/etc/cipe/ip-up-1
ipdown=(none)
arg=(none)
maxerr=8
tokxts=0
ping=0
toping=0
dynip=no
opendev: bind: Invalid argument
-----------------------------------------

Any help would be very much appreciated!

Yours Kaveh.





<< | Thread Index | >> ]    [ << | Date Index | >> ]