<< | Thread Index | >> ]    [ << | Date Index | >> ]

Subject: RE: CIPE-WIN32 pre3 Dr Watsons [was CIPE-WIN32 Routing Configuration]
From: "Matthew Kurowski" <matthew,AT,kurowski,DOT,org>
Date: Tue, 5 Dec 2000 22:48:38 +0100
In-reply-to: <200012051144400620.892FB1C3@mail-server>

I get the following error when launching cipsrvr from console or from the
service menu.

The application, cipsrvr.exe, generated an application error...<snip>
exception generated was c0000005 at address 78011f41 (fcloseall).

When launched from the console, I get the following displayed before it
dies:

[SERVICE_MANAGER] service [CIPE] has already been started
[{6F59537A-D886-4706-A1B8-966D926D8D85}] TAP started on
[\\.\{6F59537A-D886-4706-A1B8-966D926D8D85}.tap]

Note that even if the service hasn't started already, "cipsrvr console" will
still say that it has already started - at least on my 2000 machines.

Also, I can't remember this being mentioned or addressed and I don't care
right now but having another peer on the NT 4 machine will cause the access
violation error everytime cipsrvr is loaded. Removing either one of the
peers fixed that.

This 2000 machine is Server with SP1 (tried it without first). This machine
has only used the pre3 release.

After trying to switch the working 2000 machine I had last night (the
machine I had emailed the list about) over from the ppp address to the
ethernet (our public IP from the NAT box running ipchains), I can no longer
start cipsrvr either. I get the same error as on the 2000 Server listed
above (but with a different "key"). This machine is the one that was pre2
but then removed and installed with the pre3 adapter.

In each case there is only one peer (since I observed the NT4 issue, I made
sure to not have more than one peer).

Any ideas? Btw, if you'd like this is a non-secure PC that runs VNC. I can
give you access to it if you think it'd help to see the problem or run a
debug build or anything).

Danke,
Matthew

-----Original Message-----
From: owner-cipe-l,AT,inka,DOT,de [mailto:owner-cipe-l,AT,inka,DOT,de Behalf 
Of
Damion K. Wilson
Sent: Tuesday, December 05, 2000 9:45 AM
To: matthew,AT,kurowski,DOT,org
Cc: cipe-l,AT,inka,DOT,de
Subject: RE: CIPE-WIN32 Routing Configuration

There is still one outstanding bug that's not in the TODO: cipsrvr.exe may,
after an extended time, die because of a stack corruption. This has
occurred since I rewrote it in C++ and may be due to the C++ run time
library. I'm telling you this because it only happens on my NT4.0 testbed
when it is acting as a CIPE router under heavy load (stress test). Let me
know if this happens to you. Running it under the debugger is no help
because the stack is corrupted.

If you are willing to do a howto in HTML, I would be EXTREMELY
appreciative.

DKW
CIPE info and list archive:
<URL:http://sites.inka.de/~bigred/devel/cipe.html>





<< | Thread Index | >> ]    [ << | Date Index | >> ]