<< | Thread Index | >> ]    [ << | Date Index | >> ]

Subject: Strange NT BSOD behind linux firewall
From: "Mick Krippendorf" <mad.mick,AT,gmx,DOT,de>
Date: Sun, 11 Mar 2001 15:28:11 +0100

Hi,

I'm new to the list, so please tell me, if this or a similar problem has
been reported or even solved, and where i can probably find a solution.
The mailing list archive at http://sites.inka.de/bigred/archive/cipe-l/
couldn't help me.

The problem:

I'm trying to establish a cipe connection to a linux box on the internet
from an NT box *behind* a linux firewall doing masquerading. The reason
I don't want to just run cipe on the linux box is that only the NT box
should be connected and the current firewall setting is already
overcomplex.

Starting the cipe driver works, but whenever i try to start the cipe
deamon on the NT box, I immediately get a BSOD saying
IRQL_NOT_LESS_OR_EQUAL. I have found the m) entry in todo.txt file, but
it only states that "this hasn't been seen again... yet".

I tried both cipe versions CIPE-Win32 v2.0-pre5 and -pre6. I tried both
NT service packs 5 and 6a (german, because english ones can only be
installed with english NT versions). I tried it with and without
ip-forwarding enabled. Results are all the same. After three days of
rebooting I have no clue where else to look for. So any help is deeply
appreciated.

Now for the current NT configuration:

- NT 4.0 german, SP6a german

- CIPE-Win32 v2.0-pre6

- local ip address (me) = 192.168.1.130
- local cipe port = 6733

- remote ip address (peer) = a.b.c.d
- remote ip port = 6734

- local cipe PTP ip address (ipaddr) = 192.168.250.33
- remote cipe PTP ip address (ptpaddr) = 192.168.250.34

- default gateway = 192.168.1.1 (firewall with masquerading)
- 192.168.250.0/24 gateway = 192.168.250.34 (remote cipe box)

Thanks in advance,

Mick.





<< | Thread Index | >> ]    [ << | Date Index | >> ]