<< | Thread Index | >> ]    [ << | Date Index | >> ]

Subject: Strange IP change
From: Stephan von Krawczynski <skraw,AT,ithnet,DOT,com>
Date: Thu, 22 Mar 2001 17:35:34 +0100

Hello all,
Hello Olaf,

I made a strange experience yesterday in a multi-hour-midnight session trying
to do a simple cipe-link with one end fixed IP and the other T-DSL (dynamic 
ip).
I used SuSE 7.0 distribution standard installation.
T-DSL worked flawlessly out of the box.
As this distro has only cipe 1.3.0 on cds, I thought I better download some
newer version of cipe and got me 1.4.3, 1.4.5 and 1.4.6.
installed and tested and - didn't work!
The strange thing is: kernel-msg: "changing my address: a.b.c.d"
where a.b.c.d is the peers' ip-address!
I was pretty astonished - at least.
I tried to figure out what the problem is, but could not find any. I patched
output.c to disable this ip-changing, but the connection did not work anyway. 
I
found out that there are no packets transferred to the other end over the
dsl-link, regardless of patched or not patched version of cipe.
This is the same for all above versions of cipe.
And now:
I tried cipe-1.3.0 from the distro - and it worked at once. No such
kernel-messages, no problems whatsoever.

The kernel used is 2.2.16 with numerous SuSE patches. Needless to say I have
never had any problems with standard kernels (even not 2.2.16), but I needed
the dsl-patch.

Any experience with this?

Regards,
Stephan





<< | Thread Index | >> ]    [ << | Date Index | >> ]