<< | Thread Index | >> ]    [ << | Date Index | >> ]

Subject: Patch for cipe 1.5.1 and kernel 2.4.4
From: Torben Frey <cipe32,AT,gmx,DOT,de>
Date: Sun, 29 Apr 2001 16:03:22 +0200

Hello List,

apart from my other problem posted earlier, I can confirm a problem others
mentioned using the Alan Cox kernels 2.4.3 still being one in the official
kernel 2.4.4 release.

Cipe 1.5.1 is not compiling any more in the new 2.4.4 kernel, giving the
following error:

../cipe/output.c: In function `cipe_xmit':
../cipe/output.c:274: too few arguments to function `ip_select_ident'
gmake[1]: *** [output.o] Error 1

Searching the newsnet, I found a "patch" which compiles and works. This
patch changed line 274 in cipe/output.c from
ip_select_ident(iph, &rt->u.dst);
to
ip_select_ident(iph, &rt->u.dst, tunnel->sock);

Don't ask me what this really does, I am no programmer. Hope this helps
others upgrading the kernels :-)

Greetings from Munich,
Torben

-- 
GMX - Die Kommunikationsplattform im Internet.
http://www.gmx.net





<< | Thread Index | >> ]    [ << | Date Index | >> ]