<< | Thread Index | >> ]    [ << | Date Index | >> ]

Subject: cpp problem with configure script and RH7.1
From: Thomas Weber <l_cipe,AT,abyss,DOT,4t2,DOT,com>
Date: Sat, 5 May 2001 18:02:27 +0200

Hello,

it seems that the configure script of cipe-1.5.2 (and 1.4.5) is broken with 
cpp-2.96-81 which comes with RedHat 7.1.
The problem is somewhere in the AX_MACRO_STR autoconf macro which returns
an empty string when checking for the kernel version on a RH7.1 based system.
So KVERS is empty and the configure script will exit with "Unsupported kernel
version".
I also tested on a RH 7.0 system (with all the recent updates, cpp-2.96-69) 
and it works fine. Using the cpp-2.96-81 rpm from RH 7.1 on the 7.0 system 
breaks the kernel version detection (KVERS empty). 
So either the macro is somehow broken or RedHat broke the preprocessor. 
I don't know enough about the autoconf stuff to investigate further so I
thought I report this here before blaming RedHats cpp.

mfG,
  Tom





<< | Thread Index | >> ]    [ << | Date Index | >> ]