<< | Thread Index | >> ]    [ << | Date Index | >> ]

Subject: depmod -a and undefined symbols
From: Dr Jon R Malone <jon,AT,malone,DOT,scotnet,DOT,co,DOT,uk>
Date: Fri, 13 Jul 2001 00:46:45 +0200

The saga continues ....
I coaxed the downtime on the firewall to rebuild the kernel.

did a make xconfig
make [dep/clean] 
make
make install
make modules/modules_install

cleaned out my cipe directory 
started with a ./configure
rebuilt all
and lo and behold exactly the same errors as before (at least the
firewall still worked):

bash# insmod -v -f cipcb
Section 1: (.text) at 0x800b860
Section 2: (.rel.text) at 0x8012f28
Section 3: (.rodata) at 0x800ec04
Section 4: (.data) at 0x80105b0
Section 5: (.bss) at 0x8010c40
Section 6: (.stab) at 0x80109dc
Section 7: (.rel.stab) at 0x8013bc8
Section 8: (.stabstr) at 0x8013bf8
Section 9: (.comment) at 0x8010bbc
Section 10: (.shstrtab) at 0x8013f00
Section 11: (.symtab) at 0x8013f68
Section 12: (.strtab) at 0x8014b40
textseg = 0x800b860
bss_size = 4300
last byte = 0x8011d0c
module size = 25772
versioned kernel: yes
versioned module: yes
ELF kernel
ELF module
csum_partial: wrong version
memcpy_toiovec: wrong version
Failed to load module! The symbols from kernel 2.0.34 don't match 2.0.34

Do I need to fight the firewall up to a newer kernel?

I am out of my depth and would appreciate any other thoughts or
suggestions.  Things were OK on two 'tame' RH7.0s and everything worked
just topping, so I don't think I have knackered source.

jon





<< | Thread Index | >> ]    [ << | Date Index | >> ]