<< | Thread Index | >> ]    [ << | Date Index | >> ]

Subject: ciped problems
From: "John M. Choi" <johnchoi,AT,its,DOT,caltech,DOT,edu>
Date: Tue, 24 Jul 2001 07:25:43 +0200

I am trying to install CIPE v1.5.2 on 2 of our machines but am having no
luck. Both machines are starting with Slackware 8.0 (2.2.19 kernel).

I downloaded the source, compiled, and make installed it. The cipcb module
loads fine and I see:
kernel: cipcb: CIPE driver vers 1.5.2 (c) Olaf Titz 1996-2000, 100
        channels, debug=1
kernel: cipcb: cipe_alloc_dev 0
in /var/log/messages.

However, I can not get the ciped daemon to run. Nothing happens when I try
to run it (nothing appears when I 'ps -aux' and no logs are touched as
specified in /etc/cipe/ip-up).

I tried:
/usr/local/sbin/ciped-cb me=xxx.xxx.xxx.21:6789 peer=xxx.xxx.xxx.22:6543
ipaddr=10.0.1.1 ptpaddr=10.0.1.2
which causes in /var/log/messages:
kernel: cipcb: cipe_alloc_dev 0
kernel: cipcb0: alloc
kernel: cipcb0: setpar

but

'/sbin/ifconfig cipcb0' gives:
cipcb0    Link encap:IPIP Tunnel  HWaddr
          POINTOPOINT RUNNING NOARP  MTU:1442  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
and 'route' displays nothing about cipcb0.

Does SMP make a difference? I tried reading back in the mailing list
archives and there was mention of problems in v1.4.? with SMP machines.
Both machines are SMP.

Am I missing something? Can anyone please help? This is my first time
trying CIPE.

Thanks.

John





<< | Thread Index | >> ]    [ << | Date Index | >> ]