<< | Thread Index | >> ]    [ << | Date Index | >> ]

Subject: Newbie ...help ..I have checked the archive also ..still confused ...
From: Karthik Mohanasundaram <mkarthik1978,AT,yahoo,DOT,com>
Date: Fri, 16 Nov 2001 17:15:53 +0100

hi,

I am a newbie to CIPE and I am trying to setup a VPN
connection using CIPE 1.4.5. I am initially trying out
this connection within a private network .. [
experimenting with it right now .. ]

I am kind of running on a deadline .. so plz help me
out ..

I am running CIPE 1.4.5 and Mandrake 7.0 with 2.2.19
kernel on that ..

The details of my connection are :

private net 1 : 192.168.2.x
|
|
|
eth0 : 192.168.2.1
CIPE Gateway 1 ..
eth1 : 202.120.1.10
|
|
|
|
eth1 : 202.120.1.1
CIPE Gateway 2 ..
eth0 192.168.1.1
|
|
|
private net 2 : 192.168.1.x

As i am trying to simulate the network I am directly
connecting eth1's of the gateway's .. The machines on
pri.net 2 have 192.168.1.1 as their gateway and
machines on pri.net 1 have 192.168.2.1 as their
gateways ..

Options of Gateway 1 :

device          cipcb0
ptpaddr         192.168.1.1
ipaddr          192.168.2.1
me              202.120.1.10:9000
peer            202.120.1.1:9000
key             xxxxx ....

Options of Gateway 2 :

device          cipcb0
ptpaddr         192.168.2.1
ipaddr          192.168.1.1
me              202.120.1.1:9000
peer            202.120.1.10:9000
key             xxxxxx ..... [ not my original key .. ]

I am sctually using the ip-up and ip-down scripts for
ipchains that I got from the Cipe+Masq - HOWTO I got
from the linuxdoc.org mini How-To's site ...

SHOULD I WRITE MY OWN ip-up or ip-down ???

I got the Gateway's connected once and the device
[cipcb0] was enabled but i messed up the routing and
so I am trying to start that up again but there is
some problem with it that I am not able to catch up
with ..

The /var/log/messages that i got are :

---snip---
Nov 16 03:55:49 localhost kernel: cipcb: CIPE driver
vers 1.4.5 (c) Olaf Titz 1996-2000, 100 channels,
debug=1 
Nov 16 03:55:49 localhost kernel: cipcb:
cipe_alloc_dev 0 
Nov 16 03:56:05 localhost ciped-cb[840]: CIPE daemon
vers 1.4.5 (c) Olaf Titz 1996-2000
Nov 16 03:56:05 localhost kernel: cipcb0: alloc 
Nov 16 03:56:05 localhost kernel: cipcb0: setpar 
Nov 16 03:56:05 localhost kernel: cipcb0: setkey 
Nov 16 03:56:05 localhost kernel: cipcb0: attach 
Nov 16 03:56:05 localhost kernel: cipcb0: opened 
Nov 16 03:56:05 localhost kernel: cipcb0: cipe_recvmsg

Nov 16 03:56:05 localhost kernel: cipcb0: setkey 
Nov 16 03:56:05 localhost kernel: cipcb0: cipe_sendmsg

Nov 16 03:56:05 localhost kernel: cipcb0: cipe_recvmsg

Nov 16 03:56:05 localhost kernel: cipcb0: cipe_sendmsg

Nov 16 03:56:05 localhost kernel: cipcb0: setkey 
Nov 16 03:56:05 localhost kernel: cipcb0: cipe_recvmsg

Nov 16 03:56:05 localhost kernel: cipcb0: setkey 
Nov 16 03:56:05 localhost kernel: cipcb0: cipe_recvmsg

Nov 16 03:56:32 localhost kernel: cipcb0: closing 
Nov 16 03:56:32 localhost ciped-cb[840]: kxchg: recv:
Device not configured
Nov 16 03:56:32 localhost ciped-cb[840]: Interface
stats     1040       5    0    0    0     0          0
        0        0       0    0    0    0     0      
0          0  
Nov 16 03:56:32 localhost ciped-cb[840]: KX stats:
rreq=0, req=1, ind=1, indb=0, ack=1, ackb=0, unknown=0

Nov 16 03:56:32 localhost ciped-cb: options: not
absolute
Nov 16 03:56:32 localhost ciped-cb[874]: opendev:
bind: Address already in use
Nov 16 03:56:32 localhost kernel: cipcb0: sock_close 
Nov 16 03:56:32 localhost kernel: cipcb0: closed 
Nov 16 03:56:32 localhost ciped-cb[840]: cipcb0:
daemon exiting
---snip---

Again i tried to connect but this time also no success
!!!

---snip---
Nov 16 03:59:17 localhost ciped-cb[888]: CIPE daemon
vers 1.4.5 (c) Olaf Titz 1996-2000
Nov 16 03:59:17 localhost kernel: cipcb0: alloc 
Nov 16 03:59:17 localhost ciped-cb[888]: opendev:
alloc: Device or resource busy
---snip---

Is there any time gap after which I should restart the
ciped-cb server ??? [ I CHANGED THE PORT NUMBERS in
the options file ...]

PLZ help me out on this ...

karthik.

__________________________________________________
Do You Yahoo!?
Find the one for you at Yahoo! Personals
http://personals.yahoo.com





<< | Thread Index | >> ]    [ << | Date Index | >> ]