<< | Thread Index | >> ]    [ << | Date Index | >> ]

Subject: cipe-1.5.2 on sparc64, doesn't compile
From: Jan Gyselinck <cipe,AT,lists,DOT,b0rken,DOT,net>
Date: Thu, 17 Jan 2002 15:07:43 +0100

It seems that cipe-1.5.2 does not compile under the sparc64 architecture.

I'm using Linux 2.4.17 kernel, and when I try to compile cipe I get this:

gmake[1]: Entering directory `/usr/src/cipe-1.5.2/2.4.17-sparc64-SMP-cb'
ld -r -S -o cipcb.o module.o device.o sock.o output.o encaps.o bf.o
crc32.o
ld: warning: sparc:v9 architecture of input file `module.o' is incompatible
with sparc output
ld: warning: sparc:v9 architecture of input file `device.o' is incompatible
with sparc output
ld: warning: sparc:v9 architecture of input file `sock.o' is incompatible
with sparc output
ld: warning: sparc:v9 architecture of input file `output.o' is incompatible
with sparc output
ld: warning: sparc:v9 architecture of input file `encaps.o' is incompatible
with sparc output
ld: warning: sparc:v9 architecture of input file `bf.o' is incompatible
with sparc output
ld: bfd assertion fail elflink.h:2253
ld: final link failed: Bad value
gmake[1]: *** [cipcb.o] Error 1
gmake[1]: Leaving directory `/usr/src/cipe-1.5.2/2.4.17-sparc64-SMP-cb'
make: *** [all] Error 2

The problem seems to be that it tries to link sparc64 objects with a
sparc32 objectfile (crc32.o).  Anybody an idea how to fix this?

Regards

Jan G.





<< | Thread Index | >> ]    [ << | Date Index | >> ]