<< | Thread Index | >> ]    [ << | Date Index | >> ]

Subject: Re: cipcb.o unresolved symbol __read_lock_failed on 2.4.5
From: Keith Smith <keith,AT,ksmith,DOT,com>
Date: Thu, 31 Jan 2002 02:22:42 +0100
In-reply-to: <001701c1a792$dfa0b680$0202a8c0@cetialphafive.net>

Your kernel source does not match your running kernel.

You have some choice, but I might suggest simply a config and re-compile of 
your
kernel, then do the cip thing.  1.5.2 worked without a hitch here other than 
the
texinfo problems.  also note makedistclean will wipe out all of the doc files.

Also, Also note make sure your permissions on every file/directory cipe 
touches
are 0 for group and other, ie 0700 for dirs and 0600 for files.

Tyler Thueson wrote:

 > Just searched the mailing list archives but couldn't find anything about
 > this insmod/modprobe error I'm getting.
 >
 > I've just done a fresh install of Slackware 8.0 with the 2.4.5 kernel. I've
 > tried CIPE 1.5.2 and 1.4.6, and this problem appears in both (I have to 
 > hack
 > the Makefile for 1.5.2 to fix the missing cipe.texinfo file errors though)
 > (and I have to add the third ip_select_ident parameter of null for 1.4.6).
 >
 > Everything is totally stock. This is the first thing I've ever compiled on
 > this machine, in fact. The compile seems to go okay, but when I try to
 > insmod or modprobe cipcb, I get "unresolved symbol __read_lock_failed" and
 > the module refuses to load.
 >
 > I'm a bit of a Linux newbie so I'm sorry I don't have any more debugging
 > info to give. Any help on how to fix my CIPE installation is greatly
 > appreciated! Thanks in advance!
 >
 > Tyler
 >
 >
 > --
 > Message sent by the cipe-l,AT,inka,DOT,de mailing list.
 > Unsubscribe: mail majordomo,AT,inka,DOT,de, "unsubscribe cipe-l" in body
 > Other commands available with "help" in body to the same address.
 > CIPE info and list archive: 
 ><URL:http://sites.inka.de/~bigred/devel/cipe.html>
 >

-- 
Keith Smith                 keith,AT,ksmith,DOT,com
655 W Fremont Dr
Tempe AZ 85282              it's hot





<< | Thread Index | >> ]    [ << | Date Index | >> ]