<< | Thread Index | >> ]    [ << | Date Index | >> ]

Subject: RE: Trouble setting up Windows / Linux cipe connection
From: "Martin Bene" <martin.bene,AT,icomedias,DOT,com>
Date: Thu, 31 Jan 2002 18:39:29 +0100

Hi Damion, thanks for your answer.

> The CIPE local IP address can be left empty.

OK, that should help for part of the problem..

> The CIPE control panel applet has a "disable/enable" check 
> box for each peer description. This can be used to stop a 
> link from keeping a dialup link active.

I've got two problems with this:
        * when disabling a device, all key/encryption settings get removed. 
if I have to reenter these (esp. the key) every time I want to access the 
company lan, I'm not too happy.

        * usability: having to go to control panel/cipe, click the adapter, 
click enable/disable isn't really handy. Also, I've got to set a route for 
the company network when activating the cipe link. So, I'd much prefer a way 
of activating / deactivating the link that can be scripted in a .cmd file.

Would calling "cipsrvr start / cipsrvr stop" to activate/deactivate  the link 
from a cmd file work?

> Unfortunately, I've still not figured out what causes the 
> driver to crash on some Windows installations. I can't even 
> reproduce the problem consistently.

The crashes happen very consistently on my system when disabling the cipe 
network adapter in windows network settings. if there'S anything I can do to 
help fix/diagnose the problem please let me know (MS Visual C development 
environment is installed on the PC), it's my private box at home without 
anything critical installed.

> The setup that you describe is the original motivation for 
> CIPE-Win32. A accounting staff member needed access to the 
> company database while on the road with his laptop.

I still fail to get a system up and running where I hand out acompany-lan 
local IP address to the remote PC; if I use a different subnet for the 
tunneled address things work much better; I still guess that mixing the 
point-to-point interface on the unix side with a normal interface on W2K 
doesn't work too well.

Bye, Martin





<< | Thread Index | >> ]    [ << | Date Index | >> ]