<< | Thread Index | >> ]    [ << | Date Index | >> ]

Subject: client doesn't recover after server restart
From: fn ln <neplace1,AT,yahoo,DOT,ca>
Date: Sun, 10 Feb 2002 12:47:54 +0100

 Hi,

 I'm on an ADSL dialup line, so my IP can change
*anytime* :-( ... and it changes often. (several times
a day :-(

 So I need my client to quickly detect that I have new
IP. Because I think this happens when the client ciped
pings, I've put into config "ping=2" -- that way the
client kernel does "changing my address:" at most two
seconds after it comes up. But sometimes my ADSL
service goes down for even a half hour :-(

What do I do so that the client automatically recovers
when the server comes back up ?

I would appreciate any help / suggestions.

  TIA,

     John

Here is how the ciped is being run on the client :

# /usr/sbin/ciped-cb device=cipcb0 -o 
/etc/cipe/options.cipcb0 debug=1
CIPE daemon vers 1.4.5 (c) Olaf Titz 1996-2000
device=cipcb0
debug=yes
ipaddr=192.168.1.2
ptpaddr=192.168.1.1
mtu=0
metric=0
cttl=0
me=0.0.0.0:1234
peer=1.2.3.4:1234
key=(secret)
nokey=no
socks=
tokxc=0
tokey=0
ipup=(none)
ipdown=(none)
arg=(none)
maxerr=-1
tokxts=0
ping=2
toping=2
dynip=yes
Feb 10 06:20:20 step kernel: cipcb: CIPE driver vers
1.4.5 (c) Olaf Titz 1996-2000, 100 channels, debug=0
Using cipcb0 index 0
sending CT_PING
KX: [NK_REQ] sending NK_IND FA0CEB1A
KX: [NK_RREQ] sending NK_REQ
keepalive timeout
sending CT_PING
received CT_PONG
sending CT_PING
received CT_PONG
sending CT_PING
received CT_PONG
sending CT_PING
received CT_PONG
sending CT_PING
received CT_PONG
sending CT_PING
KX: [NK_REQ] sending NK_IND DFB6EDF6
received CT_PONG
KX: [NK_IND] sending NK_ACK FB76DC84
KX: [NK_ACK] got DFB6EDF6
sending CT_PING
received CT_PONG
sending CT_PING
[ repeats every 2 seconds :
received CT_PONG
sending CT_PING
]

 then the remote side is unavailable for some reason
(for example, it takes 2 minutes to reboot).

 during this time, I get :

[ repeats every 2 seconds :
keepalive timeout
sending CT_PING
] ...

 however, then the remote comes back up, is available,
and I get :

...
keepalive timeout
sending CT_PING
kxchg: recv: Connection refused
keepalive timeout
sending CT_PING
kxchg: recv: Connection refused
keepalive timeout
sending CT_PING
...

 I think the "Connection refused" is during the time
the firewall on the server side is being setup.

 however, my client just keeps saying every two
seconds:

keepalive timeout
sending CT_PING

 and it never recovers ! never ! not even after 10
minutes.

 Help !

______________________________________________________________________ 
Web-hosting solutions for home and business! http://website.yahoo.ca





<< | Thread Index | >> ]    [ << | Date Index | >> ]