<< | Thread Index | >> ]    [ << | Date Index | >> ]

Subject: ciped version mismatch, Mandrake 8.1
From: David Morgan <dmorgan,AT,telocity,DOT,com>
Date: Wed, 27 Feb 2002 04:13:42 +0100

My problem, from syslog, is:

kernel: cipcb0: ciped version mismatch c10adff6 -> 25bed682

At first I thought the quotation below from CIPE doc would yield the
solution, but apparently not. Because I recompiled the kernel, booted
the new one. Then I untarred cipe-1_5_2_tar.tar, built and installed OK
(after texinfo battles). Module loads, but running
/usr/local/sbin/ciped-cb produces that error message.

What doesn't match with what?? Do I need a different kernel version, or
distribution?

Apparently NOT the issue(?):
"Make sure you have the source, or at least the complete include tree,
of the running kernel installed (usually in `/usr/src/linux'). The
version and configuration of the kernel sources must match the kernel on
which it will run exactly, or else you risk building a module which
crashes. You also have to use the same compiler version than the one
with which the kernel was compiled. After reconfiguring and rebuilding
the kernel, don't forget to rebuild the CIPE module too. (This applies
to all externally compiled modules.) Enabling "versioned symbols" on the
kernel is strongly recommended, because it protects against version skew
between kernel and modules"

Mandrake 8.1
2.4.8-26 kernel

"uname -a" output:
Linux vpnb.ucla.edu 2.4.8-26mdk #1 Tue Feb 26 10:48:40 PST 2002 i586
unknown





<< | Thread Index | >> ]    [ << | Date Index | >> ]