<< | Thread Index | >> ]    [ << | Date Index | >> ]

Subject: RE: Unsupported kernel version
From: "Dave Brotherstone" <davegb,AT,pobox,DOT,com>
Date: Sat, 9 Mar 2002 20:37:10 +0100
In-reply-to: <3C89F97E.2234225C@cardinalengineering.com>

I think it's a specific problem with RH, in that the kernel version isn't in
the same place (I think, I only pretend to understand ;-) - I just replaced
line 1096 (ish) from KVERS=$ax_result (or whatever it is, it's
KVERS=something) to
KVERS=`uname -r`

And you'll be sorted.
Dave

>
> I am running two machines, both RH 7.2, with generic 2.4.17 kernels.
>
> When I try to run ./configure, I get:
>
> root@pythia cipe-1.5.2]# ./configure
> creating cache ./config.cache
> checking for gcc... gcc
> checking whether the C compiler (gcc  ) works... yes
> checking whether the C compiler (gcc  ) is a cross-compiler... no
> checking whether we are using GNU C... yes
> checking whether gcc accepts -g... yes
> checking how to run the C preprocessor... gcc -E
> checking for texinfo... no
> checking for tex... no
> checking for makeinfo... makeinfo
> checking for gmake... gmake
> checking for kernel include tree... /usr/src/linux-2.4.17-fresh/include
> checking for kernel compile parameters... gcc -D__KERNEL__
> -I/usr/src/linux-2.4.17-fresh/include -Wall -Wstrict-prototypes
> -Wno-trigraphs -O2 -fomit-frame-pointer -fno-strict-aliasing -fno-common
> -pipe -mpreferred-stack-boundary=2 -march=i586 -DMODULE -DMODVERSIONS
> -include /usr/src/linux-2.4.17-fresh/include/linux/modversions.h
> checking for architecture... i386
> checking for kernel version...
> configure: error: Unsupported kernel version
>
> The result is the same on both machines.  I've tried
> --with-linux=/usr/src/linux; no joy.  It finds the kernel source, but
> obviously does not like it....
>
> I think the problem is with the headers, but I have /usr/include/linux
> symlinked to /usr/src/linux/include/linux, so the version matches.....
>
> [root@pythia src]# cat /usr/include/linux/version.h
> #define UTS_RELEASE "2.4.17fresh"
> #define LINUX_VERSION_CODE 132113
> #define KERNEL_VERSION(a,b,c) (((a) << 16) + ((b) << 8) + (c))
> [root@pythia src]#
>
> It's either a configure problem, or a kernel header problem....  So
> slightly OT....
>
> Any ideas?
>
> --Yan
>
> --
> Future fighter pilots:
> Me: Akari, WHAT are you DOING?
> Akari, age 3: Pushing the envelope.
>   6:41am  up 12 days, 8 min, 18 users
>
> --
> Message sent by the cipe-l,AT,inka,DOT,de mailing list.
> Unsubscribe: mail majordomo,AT,inka,DOT,de, "unsubscribe cipe-l" in body
> Other commands available with "help" in body to the same address.
> CIPE info and list archive:
> <URL:http://sites.inka.de/~bigred/devel/cipe.html>
>





<< | Thread Index | >> ]    [ << | Date Index | >> ]