<< | Thread Index | >> ]    [ << | Date Index | >> ]

Subject: Re: got short packet from <remote peer ip>
From: Marco Palumbi <marco.palumbi,AT,tiscali,DOT,it>
Date: Thu, 20 Jun 2002 10:20:54 +0200
In-reply-to: <200206171152.24820.dwilson@ibl.bm>

Hi Damion
I have similar problems since the release of the "short packet patch" in
07 jan 2002 from Olaf Titz.

I described my problems in these messages that you can find in the list's
archive:
Date:  Tue, 22 Jan 2002 - Subject:  last patch is too much drastic?
Date:  Mon, 28 Jan 2002 - Subject:  problems with last patch

it seems to me the problem is the size of the CT_PING packet in the win32
release of cipe

recently Olaf released some new patch related to the "short packet":

Date:  Sun, 09 Jun 2002 - Subject:  [Patch] about the short packets problem

Date:  Sun, 09 Jun 2002 - Subject:  Re: [Patch] about the short packets
problem

but i have not tested them yet

thank if you can help

Marco
-- Messaggio Originale --

>I don't know how it got solved, but read the mailing list archives for
"short
>
>packet". There was something about that around cipe v1.5.x, but I'm not

>terribly aware of the details or the cause/s.
>
>It might be the static key (make sure that the keys match and are 32
>hexadecimal digits in length). Also, you don't say whether the tunnel works
>
>at all or not. You might also attempt to use a different version of CIPE
>(say
>v1.4.5) to see if anything changed in the protocol between versions that
>I
>don't handle.
>
>DKW
>
>On Monday 17 June 2002 07:37 am, Bart Boelaert wrote:
>> Does anyone know how to solve the problem as described below?
>>
>> Hello,
>>
>> I'm running CIPE 1.5.3 on a RH system with kernel 2.2.19-6.2.12. I compiled
>> CIPE and removed the cipcb.o kernel module from
>> /lib/modules/2.2.19-6.2.12/net, so that the correct kernel module which
>> CIPE installed in /lib/modules/2.2.19-6.2.12/misc is used. On the other
>end
>> I'm using CIPE for Win32 2.0-pre14 on a W2K Server system. The W2K system
>> has a dynamic IP address. The CIPE config file on the Linux system is
as
>> follows :
>>
>> ipaddr  192.168.192.254
>> ptpaddr 192.168.192.2
>>
>> me      100.100.100.100:16000
>> peer    0.0.0.0:16000
>> maxerr  -1
>> key     270bda82c3a4447d776f976c41a2ba50
>>
>> When the W2K system wants to establish a CIPE tunnel with the Linux system,
>> I get the following syslog message many times on the Linux system :
>>
>> got short packet from <remote peer ip>
>>
>> I also get a lot of RX error packets when I check the CIPE interface
>> statistics via ifconfig.
>>
>> Could somebody help me out with this nasty problem?
>>
>> Thanks in advance,
>>
>> Bart Boelaert.
>>
>> ---
>> This e-mail has been scanned when leaving our systems and is certified
>> Virus Free.
>> Checked by AVG anti-virus system (http://www.grisoft.com).
>> Version: 6.0.371 / Virus Database: 206 - Release Date: 13/06/2002
>
>
>--
>Message sent by the cipe-l,AT,inka,DOT,de mailing list.
>Unsubscribe: mail majordomo,AT,inka,DOT,de, "unsubscribe cipe-l" in body
>Other commands available with "help" in body to the same address.
>CIPE info and list archive: 
><URL:http://sites.inka.de/~bigred/devel/cipe.html>
>

__________________________________________________________________
TuttoTISCALI e' il tuo nuovo contratto di telefonia!
Chiami in tutta Italia, giorno e notte, al prezzo di un'urbana
Ti colleghi ad Internet e spendi meno di un'urbana
http://point.tiscali.it/tuttotiscali/webmail.html





<< | Thread Index | >> ]    [ << | Date Index | >> ]