<< | Thread Index | >> ]    [ << | Date Index | >> ]

Subject: Problems compiling cipe on a SMP system
From: "Nico Flemming" <nf,AT,ventas,DOT,de>
Date: Mon, 8 Jul 2002 12:07:27 +0200


Hi,
?
I have problem compiling the cipe kernel module for 
an SMP system.
I downloaded CIPE 1.4.6 and my system is SuSE-Linux 
7.0 (2.2.16-SMP).
?
The configure detects an smp system:
?
creating cache 
./config.cache???????????????????????????????????? 
checking for gcc... 
gcc?????????????????????????????????????????? 
checking whether the C compiler (gcc? ) works... 
yes????????????? 
checking whether the C compiler (gcc? ) is a cross-compiler... no 
checking whether we are using GNU C... 
yes??????????????????????? 
checking whether gcc accepts -g... 
yes??????????????????????????? 
checking whether gcc needs -fno-strict-aliasing... 
yes??????????? 
checking how to run the C preprocessor... gcc 
-E????????????????? 
checking for texinfo... 
no??????????????????????????????????????? 
checking for tex... 
no??????????????????????????????????????????? 
checking for makeinfo... 
makeinfo???????????????????????????????? 
checking for kernel include tree... /usr/src/linux-2.2.16/include 
checking for architecture... 
i386???????????????????????????????? 
checking for kernel version... 
2.2.16???????????????????????????? 
checking for SMP... 
yes?????????????????????????????????????????? 
checking for versioned symbols... 
no????????????????????????????? 
checking for assembler parts... 
bf-i386.o???????????????????????? 
checking for mlock... 
yes???????????????????????????????????????? 
checking for mlockall... 
yes????????????????????????????????????? 
updating cache 
/config.cache???????????????????????????????????? 
creating 
./config.status????????????????????????????????????????? 
creating 
Makefile???????????????????????????????????????????????? 

?
?
But a "make" and a "make install" creates and 
installs a module for 2.2.16, not
2.2.16-SMP:
?
make -C 2.2.16-i386-SMP-cb 
WHAT=install???????????????????????????? 
make[1]: Entering directory 
`/tmp/tgz/cipe-1.4.6/2.2.16-i386-SMP-cb'mkdir -p /lib/modules/2.2.16/misc 
/usr/local/sbin?????????????????? 
install -m 644 cipcb.o 
/lib/modules/2.2.16/misc???????????????????? 
install -m 755 ciped-cb 
/usr/local/sbin???????????????????????????? 
depmod 
-a?????????????????????????????????????????????????????????? 
make[1]: Leaving directory `/tmp/tgz/cipe-1.4.6/2.2.16-i386-SMP-cb' 
mkdir -p 
/usr/local/info??????????????????????????????????????????? 
install -m 644 cipe.info* 
/usr/local/info?????????????????????????? 

?
-----------------
?
# cp /lib/modules/2.2.16/misc/cipcb.o 
/lib/modules/2.2.16-SMP/misc/.
# insmod cipcb
?
Using 
/lib/modules/2.2.16-SMP/misc/cipcb.o????????????????????????????????????? 
/lib/modules/2.2.16-SMP/misc/cipcb.o: kernel-module version 
mismatch????????????/lib/modules/2.2.16-SMP/misc/cipcb.o 
was compiled for kernel version 
2.2.16?????????????????????????????????????????????????????????????????????????????while
 
this kernel is version 
2.2.16-SMP.??????????????????????????????? 

?
-----------------
?
?
Any help is highly appreciated...
?
Thanks,
Nico Flemming
VENTAS AG



<< | Thread Index | >> ]    [ << | Date Index | >> ]