<< | Thread Index | >> ]    [ << | Date Index | >> ]

Subject: Re: CIPE problems: missing argument: peer + not cipe module here?
From: Docume <docume,AT,lycos,DOT,es>
Date: Wed, 28 Aug 2002 03:07:20 +0200
In-reply-to: <200208272351.g7RNptX01133@kag.citysource.com>

> The cipe-1.4.5-9 RPM from Redhat is designed to work with their kernel
> RPMs, which include the kernel modules.
> 
> # rpm -ql kernel-2.4.18-10 | grep cipcb
> /lib/modules/2.4.18-10/kernel/drivers/addon/cipe/cipcb.o
> 
> If you don't want to use Redhat's kernel RPM, then you'll need to
> compile CIPE from source, or find a CIPE RPM from someone other than
> Redhat that includes the module.

Ok, well I am not going to use any redhat kernel anymore.
I had a lot of problems in the past with some patches.

I am now trying to compile cipe from the source code, exactly I am using 
cipe-1.5.4. It compiles correctly but 'make install' fails and the module 
show me a lot of unresolved symbols:

# modprobe cipcb
/lib/modules/2.4.19-DGD/misc/cipcb.o: unresolved symbol ip_fragment_Ree22451a
/lib/modules/2.4.19-DGD/misc/cipcb.o: unresolved symbol 
ip_route_output_key_R367b8127
/lib/modules/2.4.19-DGD/misc/cipcb.o: unresolved symbol sock_rfree_R1b5d310a
/lib/modules/2.4.19-DGD/misc/cipcb.o: unresolved symbol 
unregister_netdevice_R9779f15b
/lib/modules/2.4.19-DGD/misc/cipcb.o: unresolved symbol ___pskb_trim_R632e85b2
/lib/modules/2.4.19-DGD/misc/cipcb.o: unresolved symbol icmp_send_Rbee508e7
/lib/modules/2.4.19-DGD/misc/cipcb.o: unresolved symbol 
sk_run_filter_Rec09c15b
/lib/modules/2.4.19-DGD/misc/cipcb.o: unresolved symbol alloc_skb_R23f6cade
/lib/modules/2.4.19-DGD/misc/cipcb.o: unresolved symbol 
__ip_select_ident_R90a728a8
/lib/modules/2.4.19-DGD/misc/cipcb.o: unresolved symbol netif_rx_R99b1358f
/lib/modules/2.4.19-DGD/misc/cipcb.o: unresolved symbol 
skb_under_panic_R1a628b9d
/lib/modules/2.4.19-DGD/misc/cipcb.o: unresolved symbol dev_close_R2842df55
/lib/modules/2.4.19-DGD/misc/cipcb.o: unresolved symbol 
skb_free_datagram_R1aca0cc6
/lib/modules/2.4.19-DGD/misc/cipcb.o: unresolved symbol 
ip_finish_output_Rdfa62c16
/lib/modules/2.4.19-DGD/misc/cipcb.o: unresolved symbol __kfree_skb_Re98bfb50
/lib/modules/2.4.19-DGD/misc/cipcb.o: unresolved symbol 
register_netdevice_Rd111b63a
/lib/modules/2.4.19-DGD/misc/cipcb.o: unresolved symbol 
skb_copy_expand_R851de5b3
/lib/modules/2.4.19-DGD/misc/cipcb.o: unresolved symbol sock_wfree_R1c2cde72
/lib/modules/2.4.19-DGD/misc/cipcb.o: unresolved symbol 
skb_recv_datagram_R1a0bedbc
/lib/modules/2.4.19-DGD/misc/cipcb.o: unresolved symbol 
skb_over_panic_R586455bf
/lib/modules/2.4.19-DGD/misc/cipcb.o: unresolved symbol dev_base_R05841986
/lib/modules/2.4.19-DGD/misc/cipcb.o: insmod 
/lib/modules/2.4.19-DGD/misc/cipcb.o failed
/lib/modules/2.4.19-DGD/misc/cipcb.o: insmod cipcb failed

the same result with insmod command.

I will edit my modules.conf and I will restart the box, maybe there is the 
problem there.

Do you know the reason of those 'unresolved symbol' messages?
 
>    Are you running redhat?
> 
> I've got RH 7.2, 7.3, and 6.1 machines all connected together with CIPE.
> (Those 6.1 alphaservers get retired *real soon now*.)

Cool! :-)
I like to use cipe to connect my w2k (road-warrior) to my home linux 
server :-)

Regards, 
Docume.





<< | Thread Index | >> ]    [ << | Date Index | >> ]