<< | Thread Index | >> ]    [ << | Date Index | >> ]

Subject: Re: Question about your NDIS driver
From: Damion Wilson <dwilson,AT,ibl,DOT,bm>
Date: Fri, 22 Nov 2002 01:14:18 +0100
In-reply-to: <E7D41DF26971D51197F100B0D020EFF88DF381@kashmir.silverbacktech.com>

Ahh. So you want to start RIP or BGMP or something over the CIPE interface. I 
get it, but I've never set up Routing and Remote Access Services on Windows. 
Plainly put, when I need REAL routing, I grab a Linux or Cisco box.

It should still be possible though, but I don't know what netsh needs from 
the 
adapter to allow it to work. The routing protocols are well-defined in 
Internet RFC's and are not supposed to require anything other than a properly 
functional IP stack to work. As usual, the "clever" boys at Microsoft have 
probably added on their own twist to things.

I guess I'll have to research this one...

DKW

On Thursday 21 November 2002 06:19 pm, you wrote:
> NDIS Tester is a test harness from Microsoft to test the compliance of an
> NDIS network driver.  Unfortunately I'm not well enough versed in device
> driver programming to fully comprehend the logs it produced - but at a high
> level it looks like it identified some compliance issues w/ the driver.  I
> downloaded the test programs from
> http://www.microsoft.com/hwdq/hwtest/devices/default.asp?area=Network based
> on a recommendation on microsoft.public.development.device drivers.
>
> What I am struggling with is quite simple.  I run the following command:
> netsh routing show interface.  I see:
>
> State       Type         Interface
> ----------  -----------  ---------------------------------------------
> Enabled     Loop Back    Loopback
> Enabled     Internal     Internal
> Enabled     Dedicated    Local Area Connection
>
> CIPE, which on my system is "Local Area Connection 2", is not present.  So
> I go to add it to my list of interfaces know to R&RA with the command:
> netsh routing add interface "Local Area Connection 2".  This results in:
>
> The following interface does not exist:
> {87BC43E2-21BD-4F73-B946-9D7462FC1E0A}.  An interface with this name is not
> registered with the router.  An interface with this name is not registered
> with the router.
>
> In a nutshell all I want to do is to use the routing in Win2K to
> dynamically add routes to the CIPE interface.  If you have any thoughts
> that may lead me toward a solution, it would be appreciated.
>
> Thanks.
>
> Joe
>
> -----Original Message-----
> From: Damion Wilson [mailto:dwilson,AT,ibl,DOT,bm
> Sent: Thursday, November 21, 2002 4:48 PM
> To: Joe Kinsella
> Cc: cipe-l,AT,inka,DOT,de
> Subject: Re: Question about your NDIS driver
>
>
> I presume that you mean adding IP routes via the interface (and not the
> driver) which is most definitely implemented. I don't know what NDIS tester
> is supposed to do but I'm not inclined to spend much time there.
>
> The routing doesn't happen in CIPE, it happens in TCPIP.SYS (so chasing the
> problem using device driver testing tools may not bear fruit). You don't
> give
> details about the route commands that aren't working so I can't really
> comment any further.
>
> DKW
>
> On Thursday 21 November 2002 10:39 am, you wrote:
> > Damion,
> >
> > I was having a few odd issues w/ the CIPE virtual interface.  I ran NDIS
> > Test on it and received the below.  There were a few warnings & failures
> > before my system blue screened.  I attached the logs below.
> >
> > Does this mean anything to you?  The issue I was struggling with is that
> > I cannot add routes for this driver on Win2K.  A Microsoft engineer told
> > me to run NDIS tester to confirm it is a compliant driver.
> >
> > If you have any thoughts, it would be appreciated.
> >
> >  <<nd_cli.log>>  <<NDISTEST.LOG>>
> > Joe Kinsella
> > Director of Engineering
> > Silverback Technologies
> > http://www.silverbacktech.com
> > Phone: 978-947-5607
> > Email: jkinsella,AT,silverbacktech,DOT,com





<< | Thread Index | >> ]    [ << | Date Index | >> ]