<< | Thread Index | >> ]    [ << | Date Index | >> ]

Subject: Problems with win32 routing. Win32-Linux tunnel.
From: Roman Medina <roman,AT,rs-labs,DOT,com>
Date: Thu, 13 Feb 2003 18:30:41 +0100

 Hi,

 I'm trying to establish a cipe tunnel between a Win2k (dynamic IP)
and a Linux box (static IP). Latest versions of cipe used at both
peers. Well, as you should have guessed, it is not working. So I'm
here :-)

 I think the problem is with the win32 peer. I got to solve some
problems with the VPN virtual device (it was not visible at ipconfig),
deactivating some other network drivers (like vmware and commview
ones).

 Before posting all my config and give a possible headache to you, I'd
like to receive some more info about cipe routing on win32. Let's
summarize:

- win2k: cipe device is: 192.168.6.1
- linux: cipe device is: 192.168.7.1

 I'm trying to communicate one machine (192.168.0.1 - win2k side) with
another one (192.168.1.15 - linux side).

 Routing tables (simplified a lot, only cipe info showed):
- linux:
Destination     Gateway         Genmask         Flags Metric Ref
Use Iface
192.168.6.1     0.0.0.0         255.255.255.255 UH    0      0
0 cipcb0
192.168.0.0     192.168.6.1     255.255.255.0   UG    0      0
0 cipcb0
Default gw is internet, not showed here. This tells that packets sent
to cipe's peer (win2k, i.e., 6.1) should go through linux cipcb0. This
route is right and is placed automatically by cipe when its service is
started. The 2nd route has been added by me and tells that packets
destined to 192.168.0.x [0.1 is included here] should be tunneled
through the 1st route.

- win2k (I guess this is the problem):
===========================================================================
ILista de interfaces
0x1 ........................... MS TCP Loopback interface
0x2 ...00 50 56 c0 00 08 ...... VMware Virtual Ethernet Adapter
0x3 ...00 50 56 c0 00 01 ...... VMware Virtual Ethernet Adapter
0x1000005 ...00 08 0d 39 e5 07 ...... Intel 8255x-based Integrated
Fast Ethernet

0x2000006 ...00 53 45 00 00 00 ...... WAN (PPP/SLIP) Interface
0x2000007 ...08 00 58 00 00 01 ...... DKW Heavy Industries VPN
Adapter.
===========================================================================
===========================================================================
Rutas activas:
Destino de red        Máscara de red   Puerta de acceso   Interfaz
Métrica
      192.168.1.0    255.255.255.0      192.168.6.1     192.168.6.1
1
      192.168.6.0    255.255.255.0      192.168.6.1     192.168.6.1
1
      192.168.6.1  255.255.255.255        127.0.0.1       127.0.0.1
1
    192.168.6.255  255.255.255.255      192.168.6.1     192.168.6.1
1

 The 2nd, 3rd and 4th routes are being added by cipe VPN device. I see
differences. If this peer were also a Linux box, the cipe route should
be 192.168.7.1 through cipe. I'm not seeing this here but I don't know
how to get a similar effect using win2k on this peer.

 Any idea? What am I doing bad? :-/ Thanks in advance for your help.

 Saludos,
 --Roman

--
PGP Fingerprint:
09BB EFCD 21ED 4E79 25FB  29E1 E47F 8A7D EAD5 6742
[Key ID: 0xEAD56742. Available at KeyServ]





<< | Thread Index | >> ]    [ << | Date Index | >> ]