<< | Thread Index | >> ]    [ << | Date Index | >> ]

Subject: Re: Windows routing
From: Jake Bullet <jbullet,AT,cats,DOT,meow,DOT,at>
Date: Thu, 10 Apr 2003 21:56:57 +0200
In-reply-to: <200304091607.51975.dwilson@ibl.bm>

Yes I can ping both ends, I tried adding the route as you suggested and it
works :-D So I'm a bit puzzled as to why adding the general route to
172.16.0.0/255.255.0.0 didn't work.

Still have some issues:

a. The network between Bill and Fred now seems to work, I can ping both
ends just fine, however if I try to open a data connection, like Windows
networking or rdc it starts off working and then seems to stall.  I can
open the share, but not open any of the files.

On the server I have cipe 1.5.4 from rpm, clients are on version
2.0-pre15.  The syslog seems to be filled with the following:

Apr 10 16:32:23 kernel: cipcb1: got bogus length=9
Apr 10 16:32:23 kernel: cipcb0: got bogus length=9

Could this be an MTU problem?

b. One problem I do have it with startup/shutdown.  If I just reboot the
tunnel doesn't come back on restart.  I have to disable the interface in
the cipe control panel, reboot, reendable it.

c. I've tried adding cipe on a windows 2003 Server Beta RC2 and it works
fine, but when trying to add a static route, the CIPE interface isn't
listed as a routable interface.

Thanks for your time

Stephen

On Wed, 9 Apr 2003, Damion Wilson wrote:

> Hmmm,
> 
> Seemingly, all you'd need is a static route table entry on "Bill" to say 
>that 
> the gateway for the 172.16.1.x network is 17.16.0.1. However, this business 
> with the "tunnel failing" when route table entries are changed is pretty 
>much 
> unheard of. You don't show what the non CIPE (Ethernet, I guess) network 
> addresses are, but it's my guess that when you are changing the routing 
>table 
> entries, you're somehow invalidating the traffic needed to implement the 
> tunnel itself.
> 
> What happens when, without mucking with the routing table, the tunnel is 
> enabled and you ping 172.16.0.2 -> 172.16.0.1 ?
> 
> DKW
> 
> On Wednesday 09 April 2003 12:55 pm, Jake Bullet wrote:
> > Hello,
> >
> > I'm trying to setup a link between two VPNs.
> >
> >    Bill                    Tux                  Fred
> > 172.16.0.2        172.16.0.1 172.16.1.1      172.16.1.2
> > Windows 2k  <---->    Linux Server    <----> Windows 2k
> >              CIPE                      CIPE
> >
> > However I seem to be having some trouble with the routing.  When I try to
> > ping 172.16.1.1 from Bill the request is timing out.  Running tcpdump on
> > Bill's VPN shows that the ping requests aren't coming down the tunnel, so
> > it's not a routing issue on the linux side, Bill isn't sending the packets
> > down the tunnel at all.
> >
> > I tried rearranging the routing on Bill using the "route" command, but
> > this only seems to break the tunnel completely.  I have set the netmask on
> > each of the windows clients to be 255.255.0.0 and 255.255.255.0 on Tux in
> > the hope that the packets would get routed properly.
> >
> > The CIPE adapter doesn't seem to be acting like a normal interface as the
> > moment you do anything to the routing table the tunnel fails and the
> > tunnel has to be disabled in the cipe control panel and re-enabled to get
> > it going again.
> >
> > Can anyone please help?  It's really important that I get this working.
> >
> > P.S. I've tried it out on WindowsXP and it seems to work just fine, as too
> > for Windows 2003 Server Beta RC2.
> >
> > Stephen
> 
> 
> --
> Message sent by the cipe-l,AT,inka,DOT,de mailing list.
> Unsubscribe: mail majordomo,AT,inka,DOT,de, "unsubscribe cipe-l" in body
> Other commands available with "help" in body to the same address.
> CIPE info and list archive: 
><URL:http://sites.inka.de/~bigred/devel/cipe.html>
> 





<< | Thread Index | >> ]    [ << | Date Index | >> ]