<< | Thread Index | >> ]    [ << | Date Index | >> ]

Subject: Re: CIPE instability
From: Damion Wilson <dwilson,AT,ibl,DOT,bm>
Date: Mon, 14 Apr 2003 19:26:50 +0200
In-reply-to: <009501c30279$396562f0$1f0016ac@eng.timetra.com>

No, they aren't.

I don't know if this approach will fix this problem because the problem 
itself 
is not one that I have experienced personally. I'm loathe to muck around too 
much with the kernel driver anymore because it's always such a pain in 
Windows. That said, Michael's approach sounds like it couldn't hurt.

I know I haven't don a release for a while. I'm sorry. The next release you 
see will have major work on the service and the control panel and minor work 
on issues like this one. I don't have an ETA, though.

DKW

On Monday 14 April 2003 12:57 pm, Juan Antonio Ruiz Zwollo wrote:
> > Hmm... these sound very much like the kind of problems my MTU and
> > KeRaiseIrql fixes address. There are two more stability problems
> > remaining that I'm looking at, namely the handling of errors from the
> > WSARecvFrom call in CipeSocketIO.cpp and changing the CT_PING/CT_PONG
> > logic to match that of the Linux version to provide NAT gateway
> > keepalives. I'll let Damion and list know if I find that a fix to CIPE
> > is necessary.
>
> I have been using CIPE on W2K connected to a Linux Box for more than a year
> now and have experienced tunnel instability (every now and then the tunnel
> connetion breaks down (no pings go through) and is restored by itself after
> a few minutes (pings start flowing again)).
>
> Are the MTU and KeRaiseIrql fixes mentioned above already included in
> Version 2.0-pre15 Win32 version? I have not seen new releases for quite
> some time.
>
> Kind regards,
>
>
> Juan Antonio
>
> > -----Original Message-----
> > From: owner-cipe-l,AT,inka,DOT,de [mailto:owner-cipe-l,AT,inka,DOT,de On 
> > Behalf Of
> > Kim, Sang Dong
> > Sent: 14 April 2003 00:57
> > To: cipe-l,AT,inka,DOT,de
> > Subject: CIPE instability
> >
> > Hi all,
> >
> > I am one of  user who is using CIPE win32 more than 1 year to connect 10
> > remote PCs.
> > and I don't have Linux version of cipe. just I run two win32 cipe on NT
> > and
> > 2K.
> > But, from the starting, it doesn't show good stability on my ADSL.
> > I check firewall and both servers stability. but, I can not find any
> > problem
> > a firewall and server stability.
> > But, my ADSL lines doesn't have stability. it sometimes happening some
> > disconnections.
> > and CIPE didn't back to normal until reboot both of server.
> > Also have problem using of PCANYWHERE thru the tunnel.
> > I tried many time to solve this problem but, I can not solve it.
> > Also, it looks weak from any hackers port scan and some other attack.
> > easlily die.
> > need to reboot NT and 2K.
> > I remembered some other users have same this problem, but, can not have
> > solution.
> > And I can not use http connection thru this tunnel. it shows not stable.
> > will die soon.
> > So, I did stop most of all services in NT and win2K and  I also changed
> > OS
> > from NT to 2K. but, no effect. I can not say it is not stable but, if
> > you
> > don't have stable network then please test over 1 week before use it.
> > Anyway, unfortunately my manager is changing our structure to H/W
> > firewall
> > solution from CIPE win32.
> >
> > Bye,
> >
> > --
> > Message sent by the cipe-l,AT,inka,DOT,de mailing list.
> > Unsubscribe: mail majordomo,AT,inka,DOT,de, "unsubscribe cipe-l" in body
> > Other commands available with "help" in body to the same address.
> > CIPE info and list archive:
> > <URL:http://sites.inka.de/~bigred/devel/cipe.html>





<< | Thread Index | >> ]    [ << | Date Index | >> ]