<< | Thread Index | >> ]    [ << | Date Index | >> ]

To: cipe-l,AT,inka,DOT,de
Subject: Windows 2000 Server Routing Issues
From: Jimmy Cartrette <jimmyc,AT,inttek,DOT,net>
Date: 10 Jul 2003 18:05:52 -0400

Hi,

I have a linux box and a windows 2000 box I am trying to get to route. I
have the VPN established, i can ping on either side(currently i have the
ips at 10.1.1.2, and 10.1.1.1). I can set my routes for the windows2000
network(192.168.1.0) at the linux box, and I can ping anything on their
network. However, I can't seem to get to set up routes on the 2000 box.

I have tried the route command and also the routing tool in
administrative tools(which doesn't seem to recognize the DKW adaptor as
an interface). WHen I type
route print, I see the interface as 0x2 and it is the DKW Heavy
Industries VPN Adaptor, I see the routes to get to the other side of the
10.1.1.0 network, all seems well. But when I try

route add 192.168.20.0 mask 255.255.255.0 10.1.1.1
i get
the route addition failed: the parameter is incorrect

when i try
route add 192.168.20.0 mask 255.255.255.0 10.1.1.1 -p
i get the same error, but it actually adds the persistent route and it
shows up. HOWEVER, it only shows up, and when i tracert to the
192.168.20.0 network, it goes out the default gateway instead of the
cipe connection. 

also, under the other tools, the command line driven and graphical
routing tools under 2000, dont' recognize the interface at all i dont
think. I have loopback, internal, and local connection for the
interfaces. Under the registry, the DKW is the fourth interface, but the
2000 tools only show 3. 

Any suggestions? (I hate windows)
-- 
Jimmy Cartrette
Inttek.net Technical Support


<< | Thread Index | >> ]    [ << | Date Index | >> ]