<< | Thread Index | >> ]    [ << | Date Index | >> ]

To: Jimmy Cartrette <jimmyc,AT,inttek,DOT,net>
Subject: Re: Windows 2000 Server Routing Issues
From: Phil Scarratt <fil,AT,draxsen,DOT,com>
Date: Mon, 14 Jul 2003 17:22:38 +1000
Cc: cipe-l,AT,inka,DOT,de
Organization: Draxsen Technologies
References: <1057874752.1022.10.camel@ding.inttek.net> <3F0E14B0.4040207@draxsen.com> <1057930131.1094.10.camel@ding.inttek.net>

I remember reading that the exact same thing happened to someone else when i was doing my first cipe install on Win32 - someone had posted making it a presistent route as a fix for something. Didn't work for me - but whose gonna argue as long as it works....

Jimmy Cartrette wrote:
I got your message this morning and was going to post the relevent
sections of the route table, until I noticed that my route has
mysteriously installed itself as a normal and persistent route, and is
working correctly. It was definately NOT working last night when I gave
up. I'm not sure what the problem was, but I suppose I can blame it on
Microsoft. Or goblins. Either way, thanks for the help.


On Thu, 2003-07-10 at 21:36, Phil Scarratt wrote:


A little more info re your setup would be good....specifically which of 10.1.1.1|2 is the Win2k end? The route command to execute on the Win2k box is :

route add 192.168.20.0 mask 255.255.255.0 LINUX_CIPE_IP

EXAMPLE:
So assuming the following scenario:
Linux:
IPADDR=10.1.1.1
PTPADDR=10.1.1.2
ME=public.ip.address:9876
PEER=192.168.1.23:9876

Win2k:
IPADDR=10.1.1.2
PTPADDR=10.1.1.1
ME=192.168.1.23:9876
PEER=public.ip.address:9876

the route command on Win2k would be
route add 192.168.20.0 mask 255.255.255.0 10.1.1.1

Your win2k route output should then include something like
    10.1.1.0    255.255.255.0    10.1.1.2   10.1.1.2       1
    10.1.1.2  255.255.255.255   127.0.0.1  127.0.0.1       1
192.168.20.0    255.255.255.0    10.1.1.1   10.1.1.2       1

Fil (suffering the Win experience)

Jimmy Cartrette wrote:

Hi,

I have a linux box and a windows 2000 box I am trying to get to route. I
have the VPN established, i can ping on either side(currently i have the
ips at 10.1.1.2, and 10.1.1.1). I can set my routes for the windows2000
network(192.168.1.0) at the linux box, and I can ping anything on their
network. However, I can't seem to get to set up routes on the 2000 box.

I have tried the route command and also the routing tool in
administrative tools(which doesn't seem to recognize the DKW adaptor as
an interface). WHen I type
route print, I see the interface as 0x2 and it is the DKW Heavy
Industries VPN Adaptor, I see the routes to get to the other side of the
10.1.1.0 network, all seems well. But when I try

route add 192.168.20.0 mask 255.255.255.0 10.1.1.1
i get
the route addition failed: the parameter is incorrect

when i try
route add 192.168.20.0 mask 255.255.255.0 10.1.1.1 -p
i get the same error, but it actually adds the persistent route and it
shows up. HOWEVER, it only shows up, and when i tracert to the
192.168.20.0 network, it goes out the default gateway instead of the
cipe connection.


also, under the other tools, the command line driven and graphical
routing tools under 2000, dont' recognize the interface at all i dont
think. I have loopback, internal, and local connection for the
interfaces. Under the registry, the DKW is the fourth interface, but the
2000 tools only show 3.


Any suggestions? (I hate windows)


-- Phil Scarratt Draxsen Technologies IT Contractor/Consultant 0403 53 12 71


<< | Thread Index | >> ]    [ << | Date Index | >> ]