<< | Thread Index | >> ]    [ << | Date Index | >> ]

To: "'Phil Scarratt'" <fil,AT,draxsen,DOT,com>,"'Jimmy Cartrette'" <jimmyc,AT,inttek,DOT,net>
Subject: RE: Windows 2000 Server Routing Issues
From: "Michael Clarke" <mclarke,AT,timetra,DOT,com>
Date: Mon, 14 Jul 2003 15:18:13 +0100
Cc: <cipe-l,AT,inka,DOT,de>
Importance: Normal
In-reply-to: <3F125A3E.8080600@draxsen.com>

I've found a fix to make the CIPE interface appear in Windows 2000
Server's Routing and Remote Access tool, by modifying
cipe/disk1/OemWin2k.inf as follows before installing CIPE:

<    HKR, Ndi\Interfaces, UpperRange,   0, "ndis5"
>    HKR, Ndi\Interfaces, UpperRange,   0, "ndis4"


-----Original Message-----
From: owner-cipe-l,AT,inka,DOT,de [mailto:owner-cipe-l,AT,inka,DOT,de On 
Behalf Of
Phil Scarratt
Sent: 14 July 2003 08:23
To: Jimmy Cartrette
Cc: cipe-l,AT,inka,DOT,de
Subject: Re: Windows 2000 Server Routing Issues

I remember reading that the exact same thing happened to someone else 
when i was doing my first cipe install on Win32 - someone had posted 
making it a presistent route as a fix for something. Didn't work for me 
- but whose gonna argue as long as it works....

Jimmy Cartrette wrote:
> I got your message this morning and was going to post the relevent
> sections of the route table, until I noticed that my route has
> mysteriously installed itself as a normal and persistent route, and is
> working correctly. It was definately NOT working last night when I
> up. I'm not sure what the problem was, but I suppose I can blame it on
> Microsoft. Or goblins. Either way, thanks for the help.
> On Thu, 2003-07-10 at 21:36, Phil Scarratt wrote:
>>A little more info re your setup would be good....specifically which
>>|2 is the Win2k end? The route command to execute on the Win2k

>>box is :
>>route add mask LINUX_CIPE_IP
>>So assuming the following scenario:
>>the route command on Win2k would be
>>route add mask
>>Your win2k route output should then include something like
>>       1
>>       1
>>       1
>>Fil (suffering the Win experience)
>>Jimmy Cartrette wrote:
>>>I have a linux box and a windows 2000 box I am trying to get to
route. I
>>>have the VPN established, i can ping on either side(currently i have
>>>ips at, and I can set my routes for the
>>>network( at the linux box, and I can ping anything on
>>>network. However, I can't seem to get to set up routes on the 2000
>>>I have tried the route command and also the routing tool in
>>>administrative tools(which doesn't seem to recognize the DKW adaptor
>>>an interface). WHen I type
>>>route print, I see the interface as 0x2 and it is the DKW Heavy
>>>Industries VPN Adaptor, I see the routes to get to the other side of
>>> network, all seems well. But when I try
>>>route add mask
>>>i get
>>>the route addition failed: the parameter is incorrect
>>>when i try
>>>route add mask -p
>>>i get the same error, but it actually adds the persistent route and
>>>shows up. HOWEVER, it only shows up, and when i tracert to the
>>> network, it goes out the default gateway instead of the
>>>cipe connection. 
>>>also, under the other tools, the command line driven and graphical
>>>routing tools under 2000, dont' recognize the interface at all i dont
>>>think. I have loopback, internal, and local connection for the
>>>interfaces. Under the registry, the DKW is the fourth interface, but
>>>2000 tools only show 3. 
>>>Any suggestions? (I hate windows)

Phil Scarratt
Draxsen Technologies
IT Contractor/Consultant
0403 53 12 71

Message sent by the cipe-l,AT,inka,DOT,de mailing list.
Unsubscribe: mail majordomo,AT,inka,DOT,de, "unsubscribe cipe-l" in body
Other commands available with "help" in body to the same address.
CIPE info and list archive:

<< | Thread Index | >> ]    [ << | Date Index | >> ]