<< | Thread Index | >> ]    [ << | Date Index | >> ]

To: cipe-l,AT,inka,DOT,de
Subject: Re: Problems compiling Cipe 1.5.4 on kernel 2.4.21 (Debian)
From: Mariusz Drozdziel <mariusz,AT,teleaudio,DOT,com,DOT,pl>
Date: Mon, 21 Jul 2003 07:26:53 +0200
In-reply-to: <2210045075.20030720173214@kurgan.org>
Mail-followup-to: cipe-l@inka.de
References: <2210045075.20030720173214@kurgan.org>

On Sun, Jul 20, 2003 at 05:32:14PM +0200, Fabio Muzzi wrote:

> I  have  compiled  and  use  cipe successfully lots of times, but now,
> trying  to  compile  cipe  for  a  2.4.21  kernel  (which  I have also
> compiled from source) I get the following errors:
> make[1]: Entering directory `/usr/src/cipe-1.5.4/2.4.21mppe1-i386-cb'
> gcc -MD -DKCC_BUILD -I. -include ./config.h  -D__KERNEL__ 
> -I/usr/src/kernel-source-2.4.21/include -Wall -Wstrict-prototypes 
> -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer 
> -pipe -mpreferred-stack-boundary=2 -march=i586 -DMODULE -DMODVERSIONS 
> -include /usr/src/kernel-source-2.4.21/include/linux/modversions.h -o 
> output.o -c ../cipe/output.c
> ../cipe/output.c: In function `cipe_xmit':
> ../cipe/output.c:161: warning: implicit declaration of function 
> `ip_route_output'
> ../cipe/output.c:184: structure has no member named `pmtu'

        Since my cipe works perfectly with woody on 2.4.21, try looking
aroud mppe/mppc patch. 

-- 
                                                    Mariusz.
 
== Mariusz Drozdziel <nova,AT,eric,DOT,aquaz,DOT,pl> == 
2:482/52,AT,fidonet,DOT,org ==
== NOVA1-RIPE == GnuPG: 7CE2776F99C2C8F4613F E858D7DD1DA39F779A94 ==


<< | Thread Index | >> ]    [ << | Date Index | >> ]