<< | Thread Index | >> ]    [ << | Date Index | >> ]

To: cipe-l,AT,inka,DOT,de
Subject: Newbie questions, trying to use pkcipe
From: herve.fache,AT,philips,DOT,com
Date: Thu, 31 Jul 2003 16:09:44 +0100

I am trying to set up a tunnel, as a test between too machines. They are on 
two different subnets with a gateway in-between.

Now, I am trying to use pkcipe, as it looks simpler.

That,s what I have done:
./configure
make
modify Makefile so it does not complain about cipe.texinfo missing (install:: 
stuff)
make install
update /etc/services, /etc/inetd.conf and /etc/modules.conf (just the alias), 
then depmod -aq and restart inetd
create machine files from each other's identity file
modprobe cipcb

Questions:
- should ipaddr and ptpaddr be the same as their respective eth0 addresses, 
or something like 10.0.1.1/24 and 10.0.2.1/24?
- do I need to ifconfig cipcb0 ipaddr manually, or does pkcipe do it for me? 
I have tried and got an error (SIOCSIFFLAGS: No such device or address).
- do I need to set a route?

If I just try pkcipe -c machine1 -E, I get (either way):
connect to IP_of_machine1
/etc/cipe/pk/machine1: incorrect permissions
handlePacket: error: Signature check failed
handlePacket: received ERROR: Signature check failed

The permissions look ok though: -rw-r--r-- root root (I tried -r--r--r-- 
too). There are no firewalls AFAIK on either of the machines.

Also, /var/log/messages shows the connect from/to and then:
Jul 31 16:09:10 machine1 pkcipe[3947]: handlePacket: received ERROR: 
Signature check failed

Any clues?

Thanks in advance,
Herve.


<< | Thread Index | >> ]    [ << | Date Index | >> ]