<< | Thread Index | >> ]    [ << | Date Index | >> ]

To: herve.fache,AT,philips,DOT,com
Subject: Re: Newbie questions, trying to use pkcipe
From: Jon Bendtsen <jon+cipe,AT,silicide,DOT,dk>
Date: Mon, 04 Aug 2003 14:02:48 +0200
Cc: cipe-l,AT,inka,DOT,de
Organization: Silicide A/S
References: <OF82BD0946.2F844DDE-ON80256D78.002F7183@diamond.philips.com>
Reply-to: cipe-l,AT,inka,DOT,de

herve.fache,AT,philips,DOT,com wrote:

[cut]

If I just try pkcipe -c machine1 -E, I get (either way):
connect to IP_of_machine1
/etc/cipe/pk/machine1: incorrect permissions
handlePacket: error: Signature check failed
handlePacket: received ERROR: Signature check failed

The permissions look ok though: -rw-r--r-- root root (I tried -r--r--r-- too). There are no firewalls AFAIK on either of the machines.


they must be -rw----------


That was the problem; all works fine now! I will (this week) add a paragraph about CIPE in my on-line document (http://anapaulaandherve.me.uk/LinuxLANServer/).

May be this is worth mentioning in the examples part of the documentation (I now have found it in section 3.1)... Perhaps pkcipe itself could print something like "set your node files permissions to 600"?

Another stupid question: how do I close the connection? Killing the daemon feels Barbarian, and does not seem to close the connection at the other end...

i have the same problem. You set it up so that it autocloses after a number of errors, and make it ping often. But thats still not good
enough. I have the trouble that sometimes the users create 2 cipcbX's
with the same ip and then nothing works. :(
As for bringing it down,
ifconfig cipcbX down
works fine.


JonB


<< | Thread Index | >> ]    [ << | Date Index | >> ]