<< | Thread Index | >> ]    [ << | Date Index | >> ]

To: Phil Scarratt <fil,AT,draxsen,DOT,com>, CIPE <cipe-l,AT,inka,DOT,de>
Subject: Re: Setting up CIPE on XP
From: James Knott <james.knott,AT,rogers,DOT,com>
Date: Fri, 08 Aug 2003 21:29:12 -0400
In-reply-to: <3F31B4EB.6080003@draxsen.com>
References: <3F2E9BCA.9010402@rogers.com> <3F2F0B0F.8010309@draxsen.com> <3F317F12.2060102@rogers.com> <3F31B4EB.6080003@draxsen.com>

Phil Scarratt wrote:


James Knott wrote:
<SNIP>


In the "control panel", I have the following settings.


LAN IP Settings
Local IP Address 0.0.0.0 port 6969
Peer IP Address 24.153.22.195 port 6969. This is the box where I'd like to place the host name, rather than specific IP. However, it will not take a host name here. The name is the one issued by my ISP.



There should be no problem putting a host name there. I do, and all works fine - in fact the host name I use is from a dynamic DNS provider and all works as expected. It's just GOT to be resolvable from the local machine to the IP address of the public connection. When you say it won't take one, what exactly happens?

It'll take it now. Previously, when I tried to save the settings, it wouldn't close and the cursor would go to that box.

I suspect it may have to do with the problem below.



PTP IP Settings Local PTP Address 192.168.2.20 Peer PTP Address 192.168.2.10

And the route 192.168.2.0 net mask 255.255.255.0 shows up in the routing table.


I presume that the LAN on either end of the intended CIPE tunnel is NOT 192.168.2.0.

The firewall end is supposed to be 192.168.2.10, but the above shows up in the routing table instead.

<SNIP>


Make sure that a service named "DKW Heavy Industries VPN Adapter. Service" exists. Once the CIPE-Settings is setup correctly, the service should start and stay started. Check the task manager for a cipsrvr.exe process running. If this does not stay running, then there's a rpoblem somewhere.



It's running



I presume by "It's running" you mean cipsrvr.exe stays running. When I was initially setting up CIPE on Win32 I found it was running but would disappear after a while. This was due to misconfigured CIPE settings. Try intially without any encryption.



I haven't seen it stop yet, but then I wasn't watching for that.


<SNIP>

After all that, I can't even ping my end of the tunnel.

Also, the Linux version sets up a host route, with a net mask of 255.255.255.255. Why not the same here?


That's strange - the route thing that is, although it does explain why you can't ping your end of the tunnel. I'm on Win2k at the moment (but I've followed the exact same procedure on XP Home and all worked as with Win2k) and when all is working properly, the windows route table should have the following routes (destination mask gateway):


192.168.2.20   255.255.255.255 127.0.0.1    (this allows the ping)
192.168.2.0    255.255.255.0   192.168.2.20
192.168.2.255  255.255.255.255 192.168.2.20
remote.network 255.255.255.0   192.168.2.10 (this needs adding manually)

Here's my routes


Active Routes:
Network Destination Netmask Gateway Interface Metric
0.0.0.0 0.0.0.0 192.168.2.10 192.168.2.20 31
0.0.0.0 0.0.0.0 209.188.84.73 209.188.84.73 1
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
192.168.2.0 255.255.255.0 192.168.2.20 192.168.2.20 30
192.168.2.20 255.255.255.255 127.0.0.1 127.0.0.1 30
192.168.2.255 255.255.255.255 192.168.2.20 192.168.2.20 30
209.188.80.80 255.255.255.255 209.188.84.73 209.188.84.73 1
209.188.84.73 255.255.255.255 127.0.0.1 127.0.0.1 50
209.188.84.255 255.255.255.255 209.188.84.73 209.188.84.73 50
224.0.0.0 240.0.0.0 192.168.2.20 192.168.2.20 30
224.0.0.0 240.0.0.0 209.188.84.73 209.188.84.73 1
255.255.255.255 255.255.255.255 192.168.2.20 192.168.2.20 1
255.255.255.255 255.255.255.255 209.188.84.73 3 1
255.255.255.255 255.255.255.255 209.188.84.73 2 1
Default Gateway: 209.188.84.73
===========================================================================


How did you add that "remote.network" line. I have a route add statement in the Startup Script box.


These routes (apart from the last one) should appear as soon as the CIPE network adapter device is ENABLED. That is, even without the CIPE service running. If you don't get these as soon as the CIPE Network adapter is enabled, there's already a problem. In fact, you should be able to PING 192.168.2.20 before configuring anything on the actual CIPE side of things.

I found an error in the TCP/IP settings for the CIPE adaptor. I can now ping the notebook end, but not the firewall.

So, starting at the top:
- Stop the DKW Heavy Industries service
- Check the Network adapter configuration: all you should need to configure is the ip address and mask (192.168.2.20 255.255.255.0) - everything else can be blank.
- Enable the adapter and check the route table for the above routes.
- Once you have these routes, then move on.


Try reinstalling the adapter. Remove it, restart and reinstall.

It doesn't make a lot of sense to me - this was the easiest part on my configuration.

Hope something in all this helps.

Every time I try to do something in Windows, I'm reminded why I hate it!!!



<< | Thread Index | >> ]    [ << | Date Index | >> ]