<< | Thread Index | >> ]    [ << | Date Index | >> ]

To: "Mark Smith" <mark.smith,AT,avcosystems,DOT,co,DOT,uk>
Subject: RE: Cipe on Debian
From: Andreas Stagl <a.stagl,AT,gmx,DOT,at>
Date: Thu, 28 Aug 2003 10:56:50 +0200
Cc: "Cipe list \(E-mail\)" <cipe-l,AT,inka,DOT,de>
In-reply-to: <000201c36cc3$ed6e7ed0$d100010a@lyta>
References: <5.1.0.14.2.20030827124441.020318c0@pop.gmx.at>

Hi Mark,

At 18:52 27.08.2003 +0100, Mark Smith wrote:

<...>

Did you copy the config file to /usr/src/linux/.config, which renames it in
the process, or did you simply copy the file to /usr/src/linux?  You need to
do the former to avoid the long list of config questions and to get the same
kernel config that the stock kernel was compiled with.

Yes, I did. But it seems that the config-file from the boot-directory is not compatible with this process :-(


Therefore I did a small workaround... I also installed kernel-headers-2.4.18-bf24=2.4.18-5 because they contain the .config of the stock bf24-distribution. Using this config file, I was finally able to run at least make oldconfig, because make oldconfig dep always terminated with errors in the dep-part. Those errors where refering to some missing files like stdio.h and a lot more. I found out that this stdio.h file is part of libc6-dev... so I also installed this package and voila.... make oldconfig dep finally worked.

Then, I wanted to do the cipe-related things... so, I installed cipe-source, extracted the package and changed to the directory /usr/src/modules/cipe. There, I wanted to run "debian/rules binary-modules", but it terminated again with errors... something like "dpkg-gencontrol ..2.4.18.-bf.. wrong version" (I can't remember exactly, but note the wrong dot after 18). So, I opened debian/rules in my editor, studied the part with the dpkg-gencontrol and found out that there is a variable used called KVERS which seems to be responsible for the wrong version-info. I found the following lines....

# Yes, this is ugly.
KVERS=`sed -ne '/^\(VERSION\|PATCHLEVEL\|SUBLEVEL\|EXTRAVERSION\)/s/[^=]*= *//p' < $(KSRC)/Makefile | tr '\n' '.' | sed -e 's/.\([^.]*\)$$/\1/' -e 's/.\([^.]*
\)$$/\1/'`


....and in deed... it was "ugly" ;-) so I simply added a line below to overwrite the "wrong" KVERS with my specific version......

KVERS=2.4.18-bf2.4

.... i tried "debian/rules binary-modules" again and - it was like magic - it worked and genereted a cipe-2.4.18-bf2.4_1.5.4free-6+2.4.18-5_i386.deb in /usr/src.

I tried to install it using "dpkg -i cipe-2.4.18-bf2.4_1.5.4free-6+2.4.18-5_i386.deb" which succeeded somehow, but complained about the missing package cipe-common... so it seems, that this has also to be installed (apt-get install cipe-common). After installing this cipe-common, I installed again the cipe-2.4.18-bf2.4_1.5.4free-6+2.4.18-5_i386.deb (just to be sure... but I guess it was not necessary anyhow) and the installation finished without any warnings.

As a last thing, I changed the permissions as mentioned in the cipe.info: "For security reasons, options files must be given as absolute paths, and they and all their parent directories must be owned by root and not writable by group or other, and the options file itself must be even not readable by group or other (because it may contain secret keys)."

Well, it seems that finally cipe is now up and running on my system :-)

Of course, I still have to work a little on my iptables rules, because at the moment, I cannot "use" the new cipe interface, but that's something I will hopefully be able to solve on my own.... otherwise, I'll be back ;-)

Many, many thanks for your help & best wishes,

Andy


<< | Thread Index | >> ]    [ << | Date Index | >> ]