<< | Thread Index | >> ]    [ << | Date Index | >> ]

To: Mark Smith <mark.smith,AT,avcosystems,DOT,co,DOT,uk>
Subject: RE: cipe-win32 service fails to start
From: Rob Nelson <rnelson,AT,internoc,DOT,net>
Date: Tue, 9 Dec 2003 14:44:38 -0600 (CST)
Cc: <cipe-l,AT,inka,DOT,de>
In-reply-to: <NCBBJMDMDGNNDPEKGMOMCEIPEDAD.mark.smith@avcosystems.co.uk>

netstat -an certainly produces the result we need to see what sockets are
open. task manager shows a couple of svchosts (cipsrvr doesn't become one
of these I don't suspect), and some more normal system process, but that's
it. the daemon simply doesn't start.

> Have you verified that it's not another instance of CIPE itself running, by
> using netstat or any other tool?  I can recommend SysInternals' TCPVIEW
> (freely downloadable from www.sysinternals.com) if you want extended
> information about listening and connected sockets.

> The only other reason that springs to mind is that the value you've set in
> "Local IP Address" is not a valid address, and thus fails to bind.  Are you
> able to try different values, or failing that post a summary of your client
> configuration?

The configuration does not _seem_ to be the issue. I understand that the
cipe daemon (linux version) will terminate if it determines that the
configuration on the real UDP/IP layer is "broken" (connection refused,
ICMP unreachable, etc) IF have verified that it does act in this way (on
my linux machines) My remote server comes up, and attempts to send packets
to the windows box, but not the other way around.

But - Config is as follows:

  win32              NAT(ME)     NAT(ISP)           Server
192.168.5.3 eth0   192.168.0.1   192.168.99.1     1.2.3.4 eth0
10.0.1.2 cipcb0                                  10.0.1.1 cipcb0
55.44.33.22.11:3924 LocalIP                 PTPIP  1.2.3.4:3924

Local IP on win32 is set to it's effective IP coming out of the ISP NAT.
This works great linux->linux. I use port 3924 in both directions. (just
to make sure of the NAT traversal).

port 3924 is not in use on any machines. it is for cipe only.

I have tried the same routing configurations that worked linux->linux.
Thanks to suggestions from Mark Cooke, I have run tcpdump on everything
that I control along this route. 0 traffic comes out onto the wire.

What I would like to know is why the cpsrvr daemon seems to think that
there is a process running when there is not. If I try to STOP the cipsrvr
daemon, I am informed by the serice manager (in gui or cmd) that the
service has _already_been_stopped_!!! Has this thing jotted something down
somewhere (i.e. a .pid file, lock file - or some equivalent in the Windows
Registry?) or did it just not install correctly.

Failing fixing this, can someone give me the clues that I need to
recompile this on my windows machine. (Point me to compilers, and so on
that I might need.) I have _no_ idea how to compile stuff in a native
win32 enviroment. I have gcc and so on in the cygwin environment on the
same box ( and know how to use it, but....I don't believe this will do the
trick.)

Failing that, I would like to borrow a suitable LART, and I will subdue
the users who want this, and make them buy linux machines ;->


<< | Thread Index | >> ]    [ << | Date Index | >> ]