<< | Thread Index | >> ]    [ << | Date Index | >> ]

To: Rob Nelson <rnelson,AT,internoc,DOT,net>
Subject: Re: cipe-win32 service fails to start
From: Damion Wilson <dwilson,AT,ibl,DOT,bm>
Date: Tue, 9 Dec 2003 17:17:53 -0400
Cc: cipe-l,AT,inka,DOT,de
In-reply-to: <Pine.LNX.4.33.0312091402510.25445-100000@ns1.internoc.com>
References: <Pine.LNX.4.33.0312091402510.25445-100000@ns1.internoc.com>

Rob,

There are no cipsrvr processes that won't show up in the task manager and 
none 
of them have any other names.

Normally, a cipsrvr instance will only get upset if there's another process 
that has a socket bound to the same host:port that the new instance is trying 
to bind to. That could be another cipsrvr instance using the same 
configuration info or it could be any other windows program that uses UDP 
sockets.

Before running "cipsrvr console", make sure that there are no other 
cipsrvr.exe's running and make sure that the local UDP host:port in your 
configuration is not actively being used by any other service or process on 
the box. To be sure, you could set the local host part to be 0.0.0.0

If it still proves elusive and you want to build it yourself, you'll need 
VC++ 
6.0, The Windows NT or 2000 SDK, and the Windows NT or 2000  DDK. Those last 
two used to be downloadable but can only now be ordered on CD. Minimally, you 
can compile just cipsrvr.exe with VCC 6.0 from within its source directory by 
typing "nmake". If there are any bits missing, then I can email them to you.

DKW

On Tuesday 09 December 2003 04:44 pm, Rob Nelson wrote:
> netstat -an certainly produces the result we need to see what sockets are
> open. task manager shows a couple of svchosts (cipsrvr doesn't become one
> of these I don't suspect), and some more normal system process, but that's
> it. the daemon simply doesn't start.
>
> > Have you verified that it's not another instance of CIPE itself running,
> > by using netstat or any other tool?  I can recommend SysInternals'
> > TCPVIEW (freely downloadable from www.sysinternals.com) if you want
> > extended information about listening and connected sockets.
> >
> > The only other reason that springs to mind is that the value you've set
> > in "Local IP Address" is not a valid address, and thus fails to bind. 
> > Are you able to try different values, or failing that post a summary of
> > your client configuration?
>
> The configuration does not _seem_ to be the issue. I understand that the
> cipe daemon (linux version) will terminate if it determines that the
> configuration on the real UDP/IP layer is "broken" (connection refused,
> ICMP unreachable, etc) IF have verified that it does act in this way (on
> my linux machines) My remote server comes up, and attempts to send packets
> to the windows box, but not the other way around.
>
> But - Config is as follows:
>
>
>   win32              NAT(ME)     NAT(ISP)           Server
> 192.168.5.3 eth0   192.168.0.1   192.168.99.1     1.2.3.4 eth0
> 10.0.1.2 cipcb0                                  10.0.1.1 cipcb0
> 55.44.33.22.11:3924 LocalIP                 PTPIP  1.2.3.4:3924
>
> Local IP on win32 is set to it's effective IP coming out of the ISP NAT.
> This works great linux->linux. I use port 3924 in both directions. (just
> to make sure of the NAT traversal).
>
> port 3924 is not in use on any machines. it is for cipe only.
>
> I have tried the same routing configurations that worked linux->linux.
> Thanks to suggestions from Mark Cooke, I have run tcpdump on everything
> that I control along this route. 0 traffic comes out onto the wire.
>
> What I would like to know is why the cpsrvr daemon seems to think that
> there is a process running when there is not. If I try to STOP the cipsrvr
> daemon, I am informed by the serice manager (in gui or cmd) that the
> service has _already_been_stopped_!!! Has this thing jotted something down
> somewhere (i.e. a .pid file, lock file - or some equivalent in the Windows
> Registry?) or did it just not install correctly.
>
> Failing fixing this, can someone give me the clues that I need to
> recompile this on my windows machine. (Point me to compilers, and so on
> that I might need.) I have _no_ idea how to compile stuff in a native
> win32 enviroment. I have gcc and so on in the cygwin environment on the
> same box ( and know how to use it, but....I don't believe this will do the
> trick.)
>
> Failing that, I would like to borrow a suitable LART, and I will subdue
> the users who want this, and make them buy linux machines ;->
>
>
>
> --
> Message sent by the cipe-l,AT,inka,DOT,de mailing list.
> Unsubscribe: mail majordomo,AT,inka,DOT,de, "unsubscribe cipe-l" in body
> Other commands available with "help" in body to the same address.
> CIPE info and list archive:
> <URL:http://sites.inka.de/~bigred/devel/cipe.html>


<< | Thread Index | >> ]    [ << | Date Index | >> ]