<< | Thread Index | >> ]    [ << | Date Index | >> ]

To: SBNelson,AT,thermeon,DOT,com, cipe-l,AT,inka,DOT,de
Subject: Re: No route to peer
From: Michael Schmitz <zulu99,AT,gmx,DOT,de>
Date: Mon, 05 Jan 2004 17:11:41 +0100
In-reply-to: <7DB0958915FDD611961400A0C98F1846465AB2@WINTRIX.thermeon.com>
References: <7DB0958915FDD611961400A0C98F1846465AB2@WINTRIX.thermeon.com>

SBNelson,AT,thermeon,DOT,com wrote:

I try to use CIPE with SUSE 8.2 and ADSL. Before this I used it with ISDN and it was fine....
But now I get a error message when I start the daemon:
for peer xy Error: No route to peer....
I hope somebody can help me....


THX Michael



My guess is that CIPE is starting before you have finished connecting to
your ISP, therefore you don't have a default route.

If you are using PPPoE, I would suggest that you start CIPE after pppd is
started.  I don't know SUSE so I don't know if there is a place provided to
do that, but you should be able to edit the /etc/ppp/ip-up script to start
ciped-cb (instead of having it start automatically).  You probably should
edit the ip-down script to stop CIPE too.



I start CIPE manually. So I finish the connection before I start cipe.

"I've found the problem. I've searched it since last week. My Problem the SuSE start script. (in German: SuSE ist einfach verknaupt ) It searches a route to the peer host only through the devices, which are specified in /etc/sysconfig/network/ifcfg-xxx All other devices are ignored by SuSE. Now I tried to copy ifcfg-eth0 in ifcfg-ppp0 and change the subnet and IP in ifcfg-ppp0. And now it works. I don't know why ip-up had made problems too, maybe SuSE has changed somthing in there too. I'll find it out. And the SuSE start script breaks without anny logging in /etc/var/messages or cipe.log Thank you Christoph, your question about the routes in ip-up has waked the right idea. Daniel "

I found this in the archive. How do I have to change the IP and the subnet in ifcfg-ppp0. I only have ifcfg-dsl0.


<< | Thread Index | >> ]    [ << | Date Index | >> ]