<< | Thread Index | >> ]    [ << | Date Index | >> ]

To: Les Mikesell <les,AT,futuresource,DOT,com>
Subject: Re: Linux 2.6
From: "Dick St.Peters" <stpeters,AT,NetHeaven,DOT,com>
Date: Wed, 26 May 2004 13:21:10 -0400
Cc: cipe-l,AT,inka,DOT,de
In-reply-to: <1085588460.26051.9.camel@moola.futuresource.com>
References: <1085588460.26051.9.camel@moola.futuresource.com>

Les Mikesell writes:
> Fedora core2 seems to have removed CIPE due to incompatibility
> with the 2.6 kernel.  Is this likely to change or will it be
> necessary to change to ipsec or openvpn when upgrading?
> 
> ---
>   Les Mikesell
>    les,AT,futuresource,DOT,com

I have CIPE 1.6.0pre1 running on a number of 2.6.6 systems.  It
requires this small patch that was posted to cipe-l on April 16 by
Alexej Davidov <alexej.davidov,AT,gmx,DOT,net>:

--- cipe-linux/cipe/lebf.c      2004-03-06 23:16:41.000000000 +0100
+++ cipe-linux-fixed/cipe/lebf.c        2004-04-16 20:04:47.000000000 +0200
@@ -46,14 +46,14 @@
     .cra_blocksize = 8,
     .cra_ctxsize = sizeof(Blowfish_Key),
     .cra_name = "cipe-le-blowfish-internal",
-    .cra_cipher = {
-    .cia_ivsize = 8,
+    .cra_u = { .cipher = {
     .cia_setkey = lebf_cra_setkey,
     .cia_encrypt = lebf_encrypt,
     .cia_decrypt = lebf_decrypt,
-    },
+    }}
 };
 static struct cipher_tfm LEBF_CIPHER = {
+    .cit_ivsize = 8,
     .cit_setkey = lebf_cit_setkey,
 };

--
Dick St.Peters, stpeters,AT,NetHeaven,DOT,com 


<< | Thread Index | >> ]    [ << | Date Index | >> ]