<< | Thread Index | >> ]    [ << | Date Index | >> ]

To: cipe-l,AT,inka,DOT,de
Subject: CIPE ignores port settings specified
From: Alan Lucero <findtheegg,AT,yahoo,DOT,com>
Date: Fri, 27 Aug 2004 11:57:07 -0700 (PDT)

Hello all.

I've been using CIPE for a time and I absolutely
_love_ it.  However, I am a travelling SE, and the
main thing I use it for is tunneling out of a
customer's environment into my own home network, and
then redirecting all non-local traffic throught the
CIPE interface.   This is all well and good, however
many of my customers have an environment in which
certain ports cannot be connected to.   This is a
problem for me, as I need access to the outside world
for checking my mail, scp'ing files etc

While I don't have a problem adjusting the
/etc/services file and placing it somewhere
convienient for the initial handshaking, it's proving
troublesome to direct the ports that I am connecting
from and to for the actual CIPE traffic.  

CipeServer's /etc/cipe/pk/CipeClient file:
-----BEGIN PUBLIC KEY-----
[snip]
-----END PUBLIC KEY-----
ipaddr 192.168.8.1
ptpaddr 192.168.9.1
me [snip]:32000  
peer 0.0.0.0:32001     
device cipcb5
dynip 1
ping 10

and CipeClient's /etc/cipe/pk/CipeServer file:
-----BEGIN PUBLIC KEY-----
[snip]
-----END PUBLIC KEY-----
ipaddr 192.168.9.1
ptpaddr 192.168.8.1
me 0.0.0.0:32001
peer [snip]:32000
device cipcb5
ping 10

A sample from CipeClient's /var/log/cipe.log:
Aug 24 14:57:18 UP   cipcb5 10.5.2.164:32769 1898
192.168.9.1 192.168.8.1 SentANull
Aug 24 16:48:44 DOWN cipcb5 10.5.2.164:32769 1898
192.168.9.1 192.168.8.1 SentANull

Everything works just fine, but the ports aren't what
I requested.  I'm not sure if it's pertinent, but I do
not have an ip-up script on CipeServer....

Appreciatively,

-Lex

                
_______________________________
Do you Yahoo!?
Win 1 of 4,000 free domain names from Yahoo! Enter now.
http://promotions.yahoo.com/goldrush


<< | Thread Index | >> ]    [ << | Date Index | >> ]