<< | Thread Index | >> ]    [ << | Date Index | >> ]

To: cipe-l,AT,inka,DOT,de
Subject: newest linux kernel support
From: Larry Mulder <cipe,AT,julieandlarry,DOT,net>
Date: Sun, 07 Nov 2004 22:44:01 -0600
In-reply-to: <40E01802.9030109@rocsys.com>
References: <40E01802.9030109@rocsys.com>

Any info or success in running cipe 1.6.0 on mandrake 10.1? Just curious if doing this is currently possible with a stock mandrake kernel. It builds and compiles error free, but the daemon will not run. The lsmod command shows:

Module                  Size  Used by
.
.
.
cipcb                  34536  2560711872   <-- what's this?
.
.
.

and dmesg shows:

cipcb0: alloc
cipcb0: setpar
crypto_alloc_tfm `blowfish-internal'
cipe_alloc_tfm 'blowfish-internal'
cipe_alloc_tfm: tfm=d1024000
cipe_alloc_tfm 'blowfish-internal'
cipe_alloc_tfm: tfm=d5048000
cipe_alloc_tfm 'blowfish-internal'
cipe_alloc_tfm: tfm=d42a0000
cipcb0: setpar 0.0.0.0:0 10000 600000 0281 0
cipcb0: setkey
lebf_cit_setkey: tfm=d1024000 ctx=d102402c
cipcb0: attach

and /var/log/messages shows:

ciped-cb[3163]: CIPE daemon vers 1.6.0 (c) Olaf Titz 1996-2003
ciped-cb[3163]: opendev: attach: Socket operation on non-socket <-- problem??


strace shows invalid file descriptor errors, so I am not sure here.

BTW, this is kernel version 2.6.8.1-12mdksmp. Thanks. If I have to build a custom kernel, that's fine, I guess I am just curious if cipe is working on linux-2.6.8 or newer currently.

-Larry


<< | Thread Index | >> ]    [ << | Date Index | >> ]