<< | Thread Index | >> ]    [ << | Date Index | >> ]

To: <cipe-l,AT,inka,DOT,de>
Subject: Device or Resource busy on reconnect.
From: "Doug Milns" <doug.milns,AT,icomweb,DOT,net>
Date: Wed, 22 Dec 2004 13:27:20 -0000
Importance: Normal

Ive been using cipe 1.5.4 for some time now with slackware 8.0 very
successfully. Its proved a very effective solution. Thanks to everyone
involved with developing this!

Now a quick plea for help :)

Im now trying to use cipe 1.6.0 (have also tried with 1.5.4) on
slackware 10.0 with kernel 2.4.28, compile + install successful. Both
ends setup to use pkcipe with one end initiating connection - just as
Ive always done. The first time the connection initates perfectly and
everything works fine. If I down the connection (ifconfig cipcbX down)
it refuses to reestablish it. The syslog on the "server" end (receiving
the pkcipe request) shows :-

Dec 22 13:17:34 icom-gate ciped-cb[827]: opendev: attach: Device or
resource busy
Dec 22 13:17:34 icom-gate pkcipe[825]: ready: ciped returned 1

"ifconfig" shows no active cipecbX interfaces (although cipecb0 is still
listed in /proc/net/dev and "ifconfig cipcb0" does still return the
usual information).

I am unable to "rmmod cipcb" as it claims the module is in use. I can
find no evidence of any cipe processes still running.

I have looked through the archives and found similar reports from
someone back in Nov 2001 with cipe 1.4 but the replies from this say
this is solved in 1.5.

Reboot and the connection initiates flawlessly ... until you disconnect
it again .

Is this something with slackware 10.0? Should ifconfig be removing the
device rather than just downing it?  Where have I gone wrong ?

Thanks in advance
Doug.


<< | Thread Index | >> ]    [ << | Date Index | >> ]