[ << | Thread Index | >> ]    [ << | Date Index | >> ]

To: cipe-l,AT,inka,DOT,de
Subject: Troubles with kernel 2.4.22 compiling rel. 1.6.0
From: Emilio Primi <ep.cesip,AT,cesip,DOT,it>
Date: Wed, 4 May 2005 16:26:02 +0200
Organization: Cesip srl

Fellows,

compiling rel. 1.6.0 on a system with kernel 2.4.22, I obtain an error: the 
symbol cit_ivsize, required in lebf.c, is not defined in linux/crypto.h.

This happens also in case of configure --disable-cryptoapi.

It seems that the symbol is referred  only in order to set a default value in 
lebf.c. So, if simply I suppress the line, as in the following example, the 
compilation goes ok.

static struct cipher_tfm LEBF_CIPHER = {
  /* .cit_ivsize = 8, */
    .cit_setkey = lebf_cit_setkey,
};

Have you a better systematic approach ?
May I trust all the package is well-behaving with this bogus patch ?

Thank you.

Emilio Primi
Cesip srl
Via Libero Grassi 86/88
Prato Italia
ep.cesip,AT,cesip,DOT,it 
 


[ << | Thread Index | >> ]    [ << | Date Index | >> ]