<< | Thread Index | >> ]    [ << | Date Index | >> ]

To: cipe-l,AT,inka,DOT,de
Subject: Has anyone compiled it on a x86_64 ??
From: Andreas Billmeier <b,AT,edevau,DOT,net>
Date: Wed, 15 Mar 2006 07:27:59 +0100
Organization: Ede Vau & Partner

Hi,

can't compile on:

Linux 2.6.15.5-3w #2 SMP Sat Mar 4 15:00:12 CET 2006 x86_64
x86_64 x86_64 GNU/Linux, Opensuse10.

I already applied the 2.6.14 patch from Dick St.Peters,
which fixed a coupled of other errors.

  CC [M]  /usr/src/cipe-1.6.0/2.6.15.5-3w-x86_64-SMP-cb/output.o
/usr/src/cipe-1.6.0/2.6.15.5-3w-x86_64-SMP-cb/output.c: In function 
‘cipe_xmit’:
/usr/src/cipe-1.6.0/2.6.15.5-3w-x86_64-SMP-cb/output.c:287: warning: format 
‘%d’ expects type ‘int’, but argument 5 has type ‘long int’
  CC [M]  /usr/src/cipe-1.6.0/2.6.15.5-3w-x86_64-SMP-cb/encaps.o
  CC [M]  /usr/src/cipe-1.6.0/2.6.15.5-3w-x86_64-SMP-cb/lebf.o
  CC [M]  /usr/src/cipe-1.6.0/2.6.15.5-3w-x86_64-SMP-cb/bf.o
/usr/src/cipe-1.6.0/2.6.15.5-3w-x86_64-SMP-cb/bf.c:60: error: conflicting 
types for ‘__be32_to_cpup’
include/linux/byteorder/little_endian.h:80: error: previous definition of 
‘__be32_to_cpup’ was here
/usr/src/cipe-1.6.0/2.6.15.5-3w-x86_64-SMP-cb/bf.c:75: error: conflicting 
types for ‘__le32_to_cpup’
include/linux/byteorder/little_endian.h:56: error: previous definition of 
‘__le32_to_cpup’ was here
gmake[3]: *** [/usr/src/cipe-1.6.0/2.6.15.5-3w-x86_64-SMP-cb/bf.o] Fehler 1
gmake[2]: *** [_module_/usr/src/cipe-1.6.0/2.6.15.5-3w-x86_64-SMP-cb] Fehler 2
gmake[2]: Leaving directory `/usr/src/linux-2.6.15.5'
gmake[1]: *** [all25] Fehler 2
gmake[1]: Leaving directory `/usr/src/cipe-1.6.0/2.6.15.5-3w-x86_64-SMP-cb'
make: *** [all] Fehler 2

thx in advance.
\B.


<< | Thread Index | >> ]    [ << | Date Index | >> ]