[ << | Thread Index | >> ]    [ << | Date Index | >> ]

To: <cipe-l,AT,inka,DOT,de>
Subject: Compile CIPE in module then ship to another machine with 2.4.32 kernel
From: "Sen Ho Tam" <stam,AT,woolnetwork,DOT,com,DOT,au>
Date: Fri, 25 May 2007 16:13:44 +1000
Thread-index: AceejBitJbml8PISTs+XaGo4IGYuRQAAcctgAAF5zKA=

I am terribly sorry to trouble you with my problem.  I have an IPcop box
running and it has CIPE for inter-office connection, the box was installed
years ago in IPcop version 1.4.6, the cipcb.o is in the kernel module and
loaded from the rc.local file.

 

Until recently, I would need to upgrade the IPcop to the latest version,
currently 1.4.15 (kernel 2.4.34, I copied the cipcb.o to the new machine,
when I do a modprobe cipcb it complained about the wrong kernel.

 

I have another FC5 machine, downloaded the cipe 1.6 trying to compile one
then copy the cipcb to the IPcop 1.4.15, but I find that the kernel of the
FC5 is 2.6.xx.

 

I am wondering, is there a way of compile a matched cipcb.o copy to the
IPcop machine, as the IPcop does not have the sources and the gcc compiler.

 

I could not find the original inventor who put the cipcb.o in the machine,
in the /lib/modules/2.4.29/kernel/misc directory.

 

Many thanks in advance.


[ << | Thread Index | >> ]    [ << | Date Index | >> ]